Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80913

Summary: when using smb:/ browsing in KDE, no shares are browsable
Product: [Retired] Red Hat Linux Reporter: Need Real Name <scottf>
Component: kdebaseAssignee: Ngo Than <than>
Status: CLOSED UPSTREAM QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: smb:/ browsing in KDE broken
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-03 13:31:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2003-01-02 09:48:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
smb://hostname will return list of shares, but clicking on a share produces
nothing. the throbber in konqueror just keeps spinning.

problem occurs for both WinXP and unix/samba based file servers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. browse to smb://host
2. click on share name (e.g. smb://host/share)
    

Actual Results:  nothing happens

Expected Results:  see the contents of the share.

Additional info:

'ps -ef' reveals that smbclient //host/share -Ia.b.c.d -Uusername is running.
It's as though the KIO-smb thingy is having trouble getting info to and from
smbclient.

smbclient from the command line works perfectly.

Comment 1 Need Real Name 2003-01-02 09:49:23 UTC
rh8.0 is fully up2date. Problem occurs with both samba 2.2.5 and 2.2.7 RPMs
supplied by redhat. Haven't tried samba from source.

Comment 2 Ngo Than 2003-04-03 13:31:12 UTC
It's fixed in kde-3.1.1 which you can download from ftp.kde.org.