Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80884

Summary: redhat-config-sound is broken on Cyrix
Product: [Retired] Red Hat Linux Reporter: Alan Cox <alan>
Component: redhat-config-soundcardAssignee: Brent Fox <bfox>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Alan Cox 2003-01-01 20:37:20 UTC
Description of problem:

redhat-config-sound reports a disabled Kahula 5530 audio system. This is wrong.
The 5520/5530 audio is soundblaster16, it is supported by Linux.
redhat-config-sound seems to be making wrong decisions

Worse still it has
   no --help
   no dialog option to configure manually
   no /usr/share/doc/ files

turning it from merely an annoyance, into a complete showstopper

Comment 1 Brent Fox 2003-01-02 14:11:05 UTC
Hmm, redhat-config-soundcard gets it's probing information from kudzu.  What is
the PCI id of the card?  Maybe it's kudzu's pcitable that is confused.  Or is
this   an ISA card?

Comment 2 Alan Cox 2003-01-02 15:22:55 UTC
See email reply, but now bugzilla is back

- Cyrix 5520/5530 is a PCI audio interface with no IRQ or I/O driven by "magic"
Soundblaster emulation. 

I suspect krudzu is seeing the 5530 is a multimedia/audio class PCI device with
no I/O or IRQ and assuming it is "disabled". Thats a bug but not the big bug.
The bigger bug IMHO is that given a disabled PCI sound device
redhat-config-sound then doesn't offer the chance to configure ISA audio.


Comment 3 Brent Fox 2003-01-07 16:45:30 UTC
Yeah, redhat-config-soundcard doesn't have a way to configure ISA cards at the
moment.  I won't get to this for GinGin, so we are still shipping sndconfig.  I
hope to get this done for the next release.

Having said that, I'm not sure what I can do about this for GinGin.  Any ideas?

Comment 4 Alan Cox 2003-01-07 17:39:32 UTC
If we are still shipping sndconfig (I didnt realise we were ?) then I guess for
no PCI card
or for PCI and disabled display info about sndconfig in the dialog

"Your sound card does not appear to be PCI and we cannot automatically configure it
 for you. You may be able to configure it by hand using the 'sndconfig' tool'

??


Comment 5 Brent Fox 2003-01-14 22:40:52 UTC
Yeah, sndconfig is going to stick around until I make redhat-config-soundcard
work with ISA cards.  I'll have to see if I have any cards here that demonstrate
this behavior.  I need to know what kudzu thinks this card is before I can
notify the user that the card isn't a real PCI card.

Comment 6 Brent Fox 2003-02-05 21:25:45 UTC

*** This bug has been marked as a duplicate of 83234 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:50:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.