Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80852

Summary: Choosing a bad theme file at gnome theme selector makes it crash
Product: [Retired] Red Hat Linux Reporter: Thiago Sayao <sayao>
Component: control-centerAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-31 19:34:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Thiago Sayao 2003-01-01 02:41:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Choosing a bad theme file at gnome theme selector makes it crash.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open the theme selector
2. Choose a bad .tar.gz theme file
3. CRASH!
    

Additional info:

Comment 1 Jonathan Blandford 2003-01-21 20:36:56 UTC
I can't reproduce this.  It doesn't give great feedback when you give it a bogus
theme, but it doesn't crash.  What's the tarball you have?

Comment 2 Thiago Sayao 2003-01-21 21:43:51 UTC
I was taking another look at it and i think it crashes when you select a theme
that uses a not installed engine. Try Etria.org found at art.gnome.org.

Comment 3 Jonathan Blandford 2003-01-24 22:45:33 UTC
I can't reproduce this.  It doesn't crash for me.  Can you confirm that that's
the tarball that causes the crash for you?

Comment 4 Thiago Sayao 2003-01-24 23:45:05 UTC
Confirmed, and other tarballs found at art.gnome.org makes it crash too.
The themes i have installed:
Bluecurve
Bluecurve-blue
Bluecurve-Okaysh
Metal
Raleigh
Redmond95

Maybe on of this installed themes is causing the crash?

Comment 5 Jonathan Blandford 2003-02-13 21:47:00 UTC
I can't reproduce this at all.  I'm able to drag a URI from mozilla to the theme
manager and have it install fine.  Which version do you have?  Can you get a
backtrace at all?

Comment 6 Thiago Sayao 2003-02-14 21:46:19 UTC
These are the last messages using strace:

read(3, "\1\2\241 \0\0\0\0\363\4@\3\0\0\0\0\0\0\0\0\1\0\0\0000\204"..., 32) = 32
write(3, "+\10\1\0", 4)                 = 4
read(3, "\1\2\242 \0\0\0\0\363\4@\3\0\0\0\0\1\0\0\0\1\0\0\0000\204"..., 32) = 32
poll([{fd=6, events=POLLIN}, {fd=3, events=POLLIN}, {fd=10, events=POLLIN},
{fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14,
events=POLLIN|POLLPRI}, {fd=15, events=POLLIN|POLLPRI}, {fd=17,
events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=20, events=POLLIN}],
10, 0) = 0
ioctl(3, 0x541b, [0])                   = 0
ioctl(3, 0x541b, [0])                   = 0
poll([{fd=6, events=POLLIN}, {fd=3, events=POLLIN}, {fd=10, events=POLLIN},
{fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14,
events=POLLIN|POLLPRI}, {fd=15, events=POLLIN|POLLPRI}, {fd=17,
events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=20, events=POLLIN}],
10, 0) = 0
--- SIGSEGV (Segmentation fault) ---
write(3, "\33\10\2\0\0\0\0\0 \5\2\0\0\0\0\0+\5\1\0", 20) = 20
read(3, "\1\2\245 \0\0\0\0\363\4@\3\0\0\0\0\0\0\0\0\1\0\0\0000\204"..., 32) = 32
clone(child_stack=0, flags=0x1200011)   = 2697
wait4(2697, [WIFEXITED(s) && WEXITSTATUS(s) == 0], 0, NULL) = 2697
--- SIGCHLD (Child exited) ---
sigreturn()                             = ? (mask now [SEGV])
SYS_252(0x1, 0x3d5f, 0x5503a290, 0x81bb1af, 0x8052ec6

Comment 7 Thiago Sayao 2003-02-14 21:52:47 UTC
I was testing it again, and it fails for every theme i try to add.
I have tried with another user too (to use another config) but it crashes
the same way.

Comment 8 Ray Strode [halfline] 2005-05-12 15:47:00 UTC
Hi,
I'm going through bugs assigned to me and attempting to clean some of the older,
fixed ones up.

This bug hasn't changed in over a year old now.  Are you still seeing the problem? 

(This a batch message is being sent to all my bugs that haven't changed in a year)

Comment 9 Ray Strode [halfline] 2005-05-31 19:34:15 UTC
Hi,

This bug has been in the NEEDINFO state for at least a couple of weeks now.  I'm
going to close the bug, but if you can provide the required information feel
free to open a new report.

Thanks.

(This is a mass message being sent to a bunch of bug reports)