Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80833

Summary: 7.3 -> Phoebe upgrade results in package dependency errors
Product: [Retired] Red Hat Linux Reporter: Glen A. Foster <glen.foster>
Component: redhat-config-dateAssignee: Brent Fox <bfox>
Status: CLOSED RAWHIDE QA Contact: Preston Brown <pbrown>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-25 14:31:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Glen A. Foster 2002-12-31 19:10:03 UTC
Description of problem: During an upgrade from 7.3 (everything install) to
Phoebe, there are several package dependency problems that would result in an
unsuccessful RHN registration:

# rpm -q kernel
kernel-2.4.20-2.2
# rpm -Va --nofiles
Unsatisfied dependencies for blt-2.4u-7: libtcl.so.0, libtk.so.0
Unsatisfied dependencies for pygnome-gtkhtml-1.4.2-3: libgtkhtml.so.20
Unsatisfied dependencies for glms-1.03-14: libpanel_applet.so.0
Unsatisfied dependencies for gnomeicu-0.96.1-3: libpanel_applet.so.0
Unsatisfied dependencies for ical-2.2-26: libtcl.so.0, libtk.so.0
Unsatisfied dependencies for gcc-chill-2.96-110: gcc = 2.96-110
Unsatisfied dependencies for libgtop-examples-1.0.12-8: libguile.so.6
Unsatisfied dependencies for rpmfind-1.7-7: librpm-4.0.4.so, librpmdb-4.0.4.so,
librpmio-4.0.4.so
Unsatisfied dependencies for timeconfig-3.2.7-1: libnewt.so.0.50
Unsatisfied dependencies for glibc-debug-static-2.2.5-34: glibc = 2.2.5-34,
glibc-devel = 2.2.5-34
Unsatisfied dependencies for postgresql-tk-7.2.1-5: libtcl.so.0, libtk.so.0

Comment 1 Bill Nottingham 2003-01-01 03:29:05 UTC
pygnome-gtkhtml fixed in next build of gnome-python2.

timeconfig needs a redhat-config-date TUI and an obsoletes in redhat-config-date.

All the rest are just old dead packages.

Comment 2 Brent Fox 2003-01-03 06:10:02 UTC
I just wrote a TUI for redhat-config-date to replace timeconfig. 
redhat-config-date-1.5.7-1 should replace /usr/sbin/timeconfig with a shell
script that launches a python replacement for the timeconfig command.

For historical reasons, the name of the program will remain 'timeconfig'
although it is now a python program that uses the redhat-config-date backend.  I
also made redhat-config-date obsolete timeconfig in the spec file.

QA, please verify


Comment 3 Brent Fox 2003-05-25 14:31:25 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.