Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80831

Summary: Gnome Terminal Does not update using ssh and pine after unfocus and refocus
Product: [Retired] Red Hat Linux Reporter: westbrook
Component: vteAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description westbrook 2002-12-31 19:01:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I installed Phoebe onto this machine and when I open a gnome-terminal, ssh to my
Redhat 7.3 server, run pine 4.44, everything works as long as I don't change
focus back to nautilus.  The screen updates as expected.  However, as soon as I
change the focus to nautilus and then go back to the terminal, the screen no
longer updates as usual.  For example, I use the cursor keys to change from one
email to another and nothing seems to occur even after a long update.  I tried
the same the same thing with Konsole and it seems to work properly.  Not sure
what the problem is exactly... please email me for more details.

-steve

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open gnome-terminal - ssh to RH 7.3 server
2. Open pine 4.44
3. Change focus of window to nautilus background
4. Change focus back to terminal
5. Terminal will not update
    

Actual Results:  Terminal will not update

Expected Results:  I would expect the terminal to take the key entry and update
the screen as normal.

Additional info:

Comment 1 Nalin Dahyabhai 2003-01-14 04:28:06 UTC
If you disable "enable-mouse-in-xterm" in pine, does this stop happening?  If
so, then this is a duplicate of 80386.  I'm closing this as such, because I
believe this to be the case.  Please reopen this bug ID if you continue to see
this problem after updating to vte 0.10.9 or later, which fixes that bug.

*** This bug has been marked as a duplicate of 80386 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.