Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80753

Summary: No genhdlist in anaconda-runtime
Product: [Retired] Red Hat Public Beta Reporter: Forrest <forresttaylor2000>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: mitr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-21 16:03:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Forrest 2002-12-30 22:00:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
There is no genhdlist in the original anaconda-runtime package, and rebuilding
from source gives the same result.  Manually compiling gives this error:

[root@test-box2 BUILD]# cd anaconda-8.0.92/utils/

[root@test-box2 utils]# make
make: Nothing to be done for `everything'.

[root@test-box2 utils]# make genhdlist
cc -g -static -Wall -g -I.. -I../loader2 -I/usr/include/rpm -o genhdlist
genhdlist.c hash.c \
-lrpm -lrpmdb -lrpmio -lbz2 -lz -lpopt -lelf
genhdlist.c: In function `onePrePass':
genhdlist.c:122: warning: implicit declaration of function `rpmReadPackageHeader'
genhdlist.c: In function `onePass':
genhdlist.c:299: warning: implicit declaration of function `expandFilelist'
genhdlist.c:326: warning: implicit declaration of function `compressFilelist'
genhdlist.c: In function `main':
genhdlist.c:431: warning: unused variable `p'
genhdlist.c:432: warning: unused variable `i'
/tmp/ccrXHuHT.o(.text+0x2a0): In function `onePrePass':
/usr/src/redhat/BUILD/anaconda-8.0.92/utils/genhdlist.c:122: undefined reference
to `rpmReadPackageHeader'
/tmp/ccrXHuHT.o(.text+0x57b): In function `onePass':
/usr/src/redhat/BUILD/anaconda-8.0.92/utils/genhdlist.c:204: undefined reference
to `rpmReadPackageHeader'
collect2: ld returned 1 exit status
make: *** [genhdlist] Error 1

Version-Release number of selected component (if applicable):
anaconda-8.0.92

How reproducible:
Always

Steps to Reproduce:
1.  cd /usr/src/redhat/BUILD/anaconda-8.0.92/utils
2.  make genhdlist

Comment 1 Jeremy Katz 2002-12-31 04:48:22 UTC
Yes, hence why it's not currently included ;-)

Hoping to rewrite in python before all is said and done, else just fix the
compilation.  For now, the 8.0 (or 7.3, or 7.2, ...) genhdlist works just fine.

Comment 2 Jeremy Katz 2003-01-06 04:10:04 UTC
Fixed the compilation, will be in the next build

Comment 3 Jay Turner 2003-01-21 02:22:08 UTC
I'm getting this:

[root@test84 utils]# make genhdlist
cc -g -static -Wall -g -I.. -I../loader2 -I/usr/include/rpm -o genhdlist
genhdlist.c hash.c \
-lrpm -lrpmdb -lrpmio -lbz2 -lz -lpopt -lelf -lpthread
/usr/lib/gcc-lib/i386-redhat-linux/3.2.1/../../../librpm.a(rpminstall.o)(.text+0x1833):
In function `rpmInstall':
: the use of `mktemp' is dangerous, better use `mkstemp'

when compiling genhdlist with anaconda-8.0.94-0.20030120155450.

Comment 4 Jeremy Katz 2003-01-21 16:03:50 UTC
The mktemp error is because rpmlib uses mktemp instead of mkstemp, not my bug :)