Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80739

Summary: Nvidia kernel src.rpm does not build on Phoebe
Product: [Retired] Red Hat Linux Reporter: Everett Giles <cgiles>
Component: rpm-buildAssignee: Jeff Johnson <jbj>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: fred, jade.deane
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-30 20:11:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Everett Giles 2002-12-30 17:50:48 UTC
Description of problem:
Processing files: NVIDIA_kernel-debuginfo-1.0-3123
error: Could not open %files file
/usr/src/redhat/BUILD/${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}-${RPM_PACKAGE_RELEASE}/debugfiles.list:
No such file or directory
 
 
RPM build errors:
    user buildmeister does not exist - using root
    group buildmeister does not exist - using root
    user buildmeister does not exist - using root
    group buildmeister does not exist - using root
    Could not open %files file
/usr/src/redhat/BUILD/${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}-${RPM_PACKAGE_RELEASE}/debugfiles.list:
No such file or directory

Version-Release number of selected component (if applicable):
 NVIDIA_kernel-1.0-3123.src.rpm
 NVIDIA_kernel-1.0-4191.src.rpm

How reproducible: always


Steps to Reproduce:
1.rmbuild --rebuild NVIDIA_kernel-1.0-4191.src.rpm
2. 
3.
    
Actual results:
Error

Expected results:
buildan rpm

Additional info:

Comment 1 Jeff Johnson 2002-12-30 20:11:01 UTC
This is a packaging or redhat-rpm-config configuartion,
not rpmbuild, problem.

I'd suggest talking to NVidia about their packaging.

Comment 2 Jade E. Deane 2003-03-13 16:22:01 UTC
Some new information:

Using RH 8.0.94

[root@martini temp]# uname -a
Linux martini 2.4.20-2.48 #1 Thu Feb 13 11:52:55 EST 2003 i686 i686 i386 
GNU/Linux


[root@martini temp]# rpmbuild --rebuild NVIDIA_kernel-1.0-4191.src.rpm
Installing NVIDIA_kernel-1.0-4191.src.rpm
warning: user buildmeister does not exist - using root
warning: group buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: group buildmeister does not exist - using root
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.46554
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ cd /usr/src/redhat/BUILD
+ rm -rf NVIDIA_kernel-1.0-4191
+ /bin/gzip -dc /usr/src/redhat/SOURCES/NVIDIA_kernel-1.0-4191.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd NVIDIA_kernel-1.0-4191
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.33571
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd NVIDIA_kernel-1.0-4191
+ LANG=C
+ export LANG
+ set +e
++ rpm -q --queryformat '%{VERSION}' rpm
+ RPMVERSION=4.2
++ echo 4.2
++ awk -F . '{print $1;}'
+ RPMMAJOR=4
++ echo 4.2
++ awk -F . '{print $2;}'
+ RPMMINOR=2
++ echo 4.2
++ awk -F . '{print $3;}'
+ RPMPATCH=
+ '[' 4 -le 3 -a 2 -le 0 -a -lt 4 ']'
/var/tmp/rpm-tmp.33571: line 35: [: too many arguments
+ make nvidia.o
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts 
-Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar  -O -MD 
-D__KERNEL__
-DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES 
-D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 
-DNV_PATCHLEVEL=4191  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86       
-I. -I/lib/modules/2.4.20-2.48/build/include -Wno-cast-qual nv.c
In file included from 
/lib/modules/2.4.20-2.48/build/include/linux/vmalloc.h:8,
                 from nv-linux.h:64,
                 from nv.c:14:
/lib/modules/2.4.20-2.48/build/include/linux/highmem.h: In function 
`bh_kmap':
/lib/modules/2.4.20-2.48/build/include/linux/highmem.h:20: warning: 
pointer of type `void *' used in arithmetic
nv.c: In function `nv_kern_mmap':
nv.c:1282: warning: passing arg 1 of `remap_page_range_R839d959e' makes 
pointer from integer without a cast
nv.c:1282: incompatible type for argument 4 of 
`remap_page_range_R839d959e'
nv.c:1282: too few arguments to function `remap_page_range_R839d959e'
nv.c:1301: warning: passing arg 1 of `remap_page_range_R839d959e' makes 
pointer from integer without a cast
nv.c:1301: incompatible type for argument 4 of 
`remap_page_range_R839d959e'
nv.c:1301: too few arguments to function `remap_page_range_R839d959e'
nv.c:1387: warning: passing arg 1 of `remap_page_range_R839d959e' makes 
pointer from integer without a cast
nv.c:1387: incompatible type for argument 4 of 
`remap_page_range_R839d959e'
nv.c:1387: too few arguments to function `remap_page_range_R839d959e'
nv.c: In function `nv_get_phys_address':
nv.c:2250: warning: implicit declaration of function `pte_offset'
nv.c:2250: invalid type argument of `unary *'
make: *** [nv.o] Error 1
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.61716
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd NVIDIA_kernel-1.0-4191
+ LANG=C
+ export LANG
+ rm -f /tmp/files.lst
+ '[' -z '' ']'
++ uname -r
+ export TARGET_KERNEL=2.4.20-2.48
+ TARGET_KERNEL=2.4.20-2.48
+ '[' -d /lib/modules/2.4.20-2.48/kernel ']'
+ INSTALLPATH=/lib/modules/2.4.20-2.48/kernel/drivers/video
+ mkdir -p 
/var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.20-2.48/kernel/drivers/video
+ install -m 0444 nvidia.o 
/var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.20-2.48/kernel/drivers/video
install: cannot stat `nvidia.o': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.61716 (%install)
 
 
RPM build errors:
    user buildmeister does not exist - using root
    group buildmeister does not exist - using root
    user buildmeister does not exist - using root
    group buildmeister does not exist - using root
    Bad exit status from /var/tmp/rpm-tmp.61716 (%install)


Comment 3 Fred T. Hamster 2003-07-12 15:54:19 UTC
apparently this _is_ an rpmbuild problem and it's due to the way debug symbols
are packaged now, as opposed to in previous versions of rpm and rpmbuild. 
adding the flag:
    --define "debug_package %{nil}"
to the rpmbuild command apparently allows the package to build successfully.
nothing like trying to hit a moving target for a third-party package builder.
this information was found on:
    http://www.trilug.org/pipermail/trilug/Week-of-Mon-20030224/014648.html
thankfully.
  shouldn't this bug be re-opened until nvidia patches their installer?  since
it's redhat that changed things and caused this to break, it seems the least
redhat can do is keep a bug entry open for it until the situation is resolved.

Comment 4 Fred T. Hamster 2003-07-12 16:02:35 UTC
i have sent an email to info@nvidia.com which may or may not be heeded.  aren't
there official channels open between nvidia and redhat whereby a redhat employee
could report this situation to nvidia and get it dealt with?  hopefully so.