Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80733

Summary: hwbrowser does not show disk partitions
Product: [Retired] Red Hat Public Beta Reporter: Paul Jenner <psj>
Component: hwbrowserAssignee: Brent Fox <bfox>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: phoebeCC: katzj
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-12 14:08:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Paul Jenner 2002-12-30 16:28:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
hwbrowser shows the single hard disk (IDE Quantum Fireball) fine but shows no
partitions on it (all disk is green in the bar display).

Output from parted:

[root@localhost root]# parted /dev/hda print
Disk geometry for /dev/hda: 0.000-14324.625 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031   2047.346  primary   fat32       boot
2       2047.346   8024.655  primary   ext3
3       8024.656  14323.579  extended
5       8024.687  12135.036  logical   ext3
6      12135.067  12393.896  logical   linux-swap
7      12393.927  14323.579  logical   ext3
Information: Don't forget to update /etc/fstab, if necessary.

Version-Release number of selected component (if applicable):
hwbrowser-0.7-1

How reproducible:
Always

Steps to Reproduce:
1. run hwbrowser
2. go to the disk view

Actual Results:  No partitions are shown.

Expected Results: I recall from earlier versions that the main bar should be
split into graphical partition 'slices' and the table below should list the
partitions.

Comment 1 Paul Jenner 2003-01-04 17:22:19 UTC
Quick confirmation that this is a regression from 8.0. hwbrowser-0.6-1 in Red
Hat 8.0 does show the contents of the same disk fine.

Comment 2 Brent Fox 2003-01-09 17:37:14 UTC
I think the parted Python bindings changed and changes were not made to hwbrowser.

Comment 3 Brent Fox 2003-01-09 19:13:48 UTC
cc'ing jeremy since he knows what changed in the parted bindings.

Comment 4 Jeremy Katz 2003-01-09 21:05:07 UTC
Fixed in 0.8-1

Comment 5 Paul Jenner 2003-01-12 14:08:15 UTC
Confirmed fixed on my system in 0.8-1 from Rawhide.