Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80720

Summary: Blank "Disk Space" popup on upgrade
Product: [Retired] Red Hat Linux Reporter: Wade Minter <minter>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Wade Minter 2002-12-30 13:39:59 UTC
Description of problem:

Performing an upgrade from GinGin2 (8.0.91) to Phoebe-1.  Installer does the
steps for an upgrade, goes to the "About To Upgrade" screen, I hit Next, it
looks at the packages, prereqs, etc., and then pops up a blank "Ok" popup that
is titled "Disk Space".

Switching to VC-2, I see that /mnt/sysimage has 5.5G available, and
/mnt/sysimage/boot has 85M available, so I'm not sure which disk space it was
complaining about.  

Hitting "Ok" at this prompt took me back to the "Ready to install Linux - hit
"Next" to begin" screen.  I hit Next, it churned, then popped up the same Disk
Space popup again.

This loop continues ad-nauseum, and I can't get to the point of actually
installing the packages, thus my upgrade fails.

There is either a calculation problem reporting a false diskspace error, or the
error message needs to provide useful information to track down the problem
partition.

Comment 1 Wade Minter 2002-12-30 13:41:04 UTC
The F2 console also showed "Error: db4 error from db(2): No such file or
directory", if that's a clue.

Comment 2 Jeremy Katz 2002-12-31 04:41:13 UTC
The error on tty2 isn't all that helpful -- what were the messages on tty3
about?  (upgrades between betas aren't supported, so this might be a package
problem that isn't going to be cared about)

Comment 3 Wade Minter 2003-01-01 00:08:09 UTC
Looking at VC3, I found the following (transcribed) error:

WARNING: Unhandled problem returned from transaction set type 6 (FILENAME HERE)
conflicts between attempted installation of kdesdk-3.1-0.3 and kdelibs-3.1-0.5

The filenames given (there was more than a screenful) appeared to be documents
in /usr/share/doc for cervesia (sp?).  Booting back into Beta 2, rpm -e kdesdk,
and restarting the upgrade allowed me to proceed.

Could it be a case of the same docs being included in two different packages?

Comment 4 Jeremy Katz 2003-01-03 22:00:37 UTC

*** This bug has been marked as a duplicate of 80771 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.