Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80701

Summary: Anaconda post-install hang
Product: [Retired] Red Hat Public Beta Reporter: Ethan Bonick <etbonick>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED WORKSFORME QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: etbonick
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-28 05:57:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Ethan Bonick 2002-12-30 03:40:38 UTC
Description of problem:
Anaconda dies on 16% of postinstall during ftp install. This is a fresh install

Version-Release number of selected component (if applicable):
8.92

How reproducible:
install via ftp

Steps to Reproduce:
1.start install process
2.
3.
    
Actual results:
anaconda crashes

Expected results:
postinstall finishes 

Additional info:
athlon 800
4.3GB hard drive
128mb RAM

Comment 1 Paul Jenner 2002-12-30 16:11:11 UTC
I can confirm the same thing.

Method:

1) floppy boot disk with network driver supplemental disk
2) network card is 3Com 3c503 (Etherlink II?)
3) install by ftp from Red Hat mirror site
4) all runs fine (set-up, package selection, package install) up to post
installation config which hangs at 16% with no obvious way out or error

The last action logged in the VT which shows what anaconda is doing is cpio
copying the network driver (3c503) to /lib/modules on the installation target
filesysten.

Comment 2 Michael Fulbright 2003-01-02 22:25:58 UTC
Looks like a driver disk issue perhaps.



Comment 3 Jeremy Katz 2003-01-03 06:44:57 UTC
If you switch to tty2, do you see the module copied to where it says it's being
extracted to?

Comment 4 Ethan Bonick 2003-01-03 23:28:08 UTC
tty3:# running: 'cd /mnt/sysimage/lib/modules; gunzip < /t,p/ramfsDD-
0/modules.cgz |/mnt/sysimage/bin/cpio --quiet -iumd 2.4.20-2.2/3c59x.'

more of the error message was printed in tty1 right after rpm install but I 
couldnt read it. I dont know if it freezes at post install or before. I was 
watching it this time and the errors started on the screen before the post-
install box came up. is there a way to log all errors to a file?

Comment 5 Jeremy Katz 2003-01-08 22:23:50 UTC
I don't get hangs after doing the copy -- how much RAM is in your system?

Comment 6 Ethan Bonick 2003-01-09 00:23:10 UTC
128 Mb will put another 128 in and see if it works


Comment 7 Jeremy Katz 2003-01-10 07:30:32 UTC
So is this reproducible?

Comment 8 Ethan Bonick 2003-01-10 12:03:21 UTC
Install worked fine after having 256Mb of Ram installed

Comment 9 Jeremy Katz 2003-01-28 05:57:14 UTC
I haven't been able to reproduce this and can't see anything in the code that
would lead me to understand why it would happen.