Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80686

Summary: gfloppy segfaults every time
Product: [Retired] Red Hat Public Beta Reporter: Sean E. Millichamp <sean>
Component: gnome-utilsAssignee: Jonathan Blandford <jrb>
Status: CLOSED RAWHIDE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: bnocera, ddumas, hp, mitr, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-24 16:12:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Sean E. Millichamp 2002-12-29 21:55:14 UTC
Description of problem:
I am testing out Phoebe as a standard user on a fresh install.  I ran "Floppy
Formatter" and it immediately crashed.

Version-Release number of selected component (if applicable):
gnome-utils-2-1.4-2

How reproducible:
Every time.

Steps to Reproduce:
1. Run "Floppy Formatter" from the Red Hat menu
2. Watch it crash
    
Actual results:
Application "gfloppy" has crashed due to a fatal error. (Segmentation fault)
Backtrace was generated from '/usr/bin/gfloppy'

(no debugging symbols found)...0x40729bc2 in waitpid ()
   from /lib/i686/libpthread.so.0
#0  0x40729bc2 in waitpid () from /lib/i686/libpthread.so.0
#1  0x4007a2e5 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x42075608 in strcmp () from /lib/i686/libc.so.6
#4  0x0804bfec in main ()
#5  0x42015970 in __libc_start_main () from /lib/i686/libc.so.6

Expected results:
Anything other then a crash.

Additional info:

Comment 1 Warren Togami 2002-12-30 00:28:24 UTC
I installed gnome-utils-debuginfo and saw this text in the terminal when gfloppy
crashed.

dlopen failed on 'libthread_db.so.1' - /lib/i686/libthread_db.so.1: undefined
symbol: ps_get_thread_area
GDB will not be able to debug pthreads.

Comment 2 Warren Togami 2003-01-23 10:25:44 UTC
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1086173536 (LWP 27370)]
0x42077fe8 in strcmp () from /lib/tls/libc.so.6

Comment 3 Bastien Nocera 2003-01-23 10:33:54 UTC
*** Bug 82481 has been marked as a duplicate of this bug. ***

Comment 4 Jonathan Blandford 2003-01-24 16:12:21 UTC
The old spec file wasn't installing a schema.  It now is, but you prolly need to
reset the key by doing something like:

gconftool-2 -s /apps/gfloppy/default_fs -t string ext2

There's better error checking filed upstream at:
http://bugzilla.gnome.org/show_bug.cgi?id=104333