Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8068

Summary: Printing _still_ broken
Product: [Retired] Red Hat Linux Reporter: andy
Component: printtoolAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: andrew.pickin, nalin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-05 02:17:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description andy 1999-12-30 17:43:46 UTC
Please note I have the module.

[root@neuromancer andy]# head -1 /etc/conf.modules
alias parport_lowlevel parport_pc
[root@neuromancer log]# /sbin/lsmod | grep ^par
parport_pc              5620   1  (autoclean)
parport                 7124   1  (autoclean) [parport_pc lp]

As of 30th Dec 1999 I have latest (rawhide) printtool/rhs-printfilters.

I can get printtool to detect my Canon 610 (sometimes).
But I have never managed to get any output.

[root@neuromancer log]# /etc/rc.d/init.d/lpd restart
Shutting down lpd:                                         [  OK  ]
Starting lpd:                                              [  OK  ]
[root@neuromancer andy]# lpr foo.c
lpr: connect: Connection refused
jobs queued, but cannot start daemon.

Even with the module I can not detect the printer a second time
for another queue.

Completely broken and nothing logged anywhere.

AMP

Comment 1 andy 2000-01-02 12:05:59 UTC
After including the extra line in conf.modules the line

modprobe: can't locate module char-major-108

is reported all over the place, particually ppp.

lpd (sometimes) also reports
parport0: detected irq 7; use procfs to enable interrupt-driven operation.
&
parport0: no IEEE-1284 device present.

procinfo has nothing under irq7 - it's not even listed.

Q. which module is char-major-108, how can I find out what make options are
required?
Q. how do i get proc to see irq7/parrallel port?

AMP

Comment 2 Bernhard Rosenkraenzer 2000-01-18 10:19:59 UTC
Does lpr 0.48 fix this?
Also, since it's complaining about a missing char-major-108, I'd assume you're
using a custom kernel. Which version?
char-major-108 is /dev/ppp, does adding
	alias char-major-108 ppp
to /etc/conf.modules get rid of this?
Is your printer port in the BIOS set to EPP, ECP, Bidirectional or SPP?

Comment 3 andy 2000-01-20 18:55:59 UTC
I've tried all bios settings &
lpr 0.48 preset - no doesn't fix problem

lpd reports
kernel: parport0:detected irq 7 use procfs to enable interrupt-driven
operation.
kernel: parport0: no IEEE-1284 device present.
kernel: lp0: using parport0 (polling).
kernel is version 2.2.12

printtool still can't detect printer

irq 7 is correct which parrallel port bios setting do you recommend?

Comment 4 Nalin Dahyabhai 2000-02-05 02:17:59 UTC
The ppp warning is normal for a 2.2 kernel when pppd tries to determine if the
kernel supports /dev/ppp-style devices, something that isn't present in 2.2.x.

What are the contents of your /etc/printcap file?

Comment 5 Bernhard Rosenkraenzer 2000-08-03 12:03:33 UTC
Closed due to lack of user input