Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80550

Summary: nautilus don't catch umount cdrom
Product: [Retired] Red Hat Linux Reporter: Féliciano Matias <feliciano.matias>
Component: nautilusAssignee: Alexander Larsson <alexl>
Status: CLOSED DUPLICATE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: lenh_jea, michael.wardle, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Féliciano Matias 2002-12-27 21:15:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When mounting a cdrom, nautilus put an icon on the desktop.
I mount two cdrom : /mnt/cdrom and /mnt/cdrom1 (dvd driver).
I umount the two cdrom with :
$ umount /mnt/cdrom*

Only one icon is deleted from the desktop.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mount two cdrom
2. umount the two cdrom with "umount /mnt/cdrom*"

Actual Results:  Nautilus don't delete all icons corresponding of the umounted
cdrom.

Expected Results:  Nautilus delete the icons of cdrom when umount cdrom.

Comment 1 Michael Wardle 2003-01-14 03:39:54 UTC
I think Nautilus does not use FAM to detect changes on read-only drives.

Adding self to CC list...


Comment 2 LENHOF 2003-01-27 09:20:59 UTC
I confirm the problem.... fam has sometime a lock on files on my CDROM....

[root@mylinux root]# umount /mnt/cdrom
umount : /mnt/cdrom : périphérique occupé
[root@mylinux root]# lsof /mnt/cdrom
COMMAND  PID USER   FD   TYPE DEVICE  SIZE   NODE NAME
fam     4787 root   30r   DIR   22,0 18432 100958 /mnt/cdrom/books/apache
fam     4787 root   31r   DIR   22,0 10240 103998 /mnt/cdrom/books/linux-sys
[root@mylinux root]# ps -edf|grep fam
root      4787  4394  0 06:55 ?        00:00:00 fam
root      6533  6475  0 10:12 pts/0    00:00:00 grep fam
[root@mylinux root]# kill -HUP 4787
[root@mylinux root]# umount /mnt/cdrom
[root@mylinux root]#

I think this need to be fixed.... because people who want to use nautilus only
not necessarly know the command line

Regards,

Comment 3 Alexander Larsson 2003-01-27 16:38:46 UTC
What sort of files did you open in /mnt/cdrom/books/apache and
/mnt/cdrom/books/linux-sys? And in what app?


Comment 4 Alexander Larsson 2003-10-22 10:24:20 UTC

*** This bug has been marked as a duplicate of 78324 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.