Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80541

Summary: Can't compile anything
Product: [Retired] Red Hat Linux Reporter: Nicholas Fitzgerald <nick>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: michael
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-03 11:17:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nicholas Fitzgerald 2002-12-27 19:55:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
I can't compile anything without getting errors. I've tried both recompiling the
kernal use the "Building a Custom Kernal" instructions in Appendix A of the
Customization Guide. I've also tried doing a source install of mysql, same results.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.make bzImage

Actual Results:  everything seems to go fine, then the process just dies and
leaves the error information shown below in "Additional Information".

Expected Results:  It should have built the kernal or mysql binaries.

Additional info:

Here is the results I get when compiling:

open.c: In function `sys_access':
open.c:382: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
make[2]: *** [open.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.18-19.8.0/fs'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-19.8.0/fs'
make: *** [_dir_fs] Error 2

Comment 1 Michael Lee Yohe 2002-12-27 20:01:26 UTC
Many isolated GCC errors are due to ailing hardware.  You say that you are
unable to compile with gcc for multiple source packages (kernel, mysql, etc.). 
Are you overclocking your system?  Is the system old or a relatively new system?

Comment 2 Nicholas Fitzgerald 2002-12-27 21:18:26 UTC
The system is as follow:
MSI 694D Pro2 MB
Dual PIII 1GHz
2 gig memory
Sony 52x CD
HDD on Primary Master: IBM-DTLA-305040 40 gig
HDDs (2) on Promise FastTrack 100 RAID: Seagate ST380021A 80 gig
Video is SIS AGP with 4meg

All of this hardware has been purchased new within the last 2 years.

Comment 3 Richard Henderson 2004-10-03 11:17:44 UTC
No test case.  Problem description points to hardware.  Two years old.