Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80518

Summary: gstreamer-plugins-devel is needed for non-devel packages
Product: [Retired] Red Hat Public Beta Reporter: Marcel Mol <marcel>
Component: gstreamer-pluginsAssignee: Colin Walters <walters>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: jrb
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-09 04:59:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Marcel Mol 2002-12-27 15:36:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021223

Description of problem:
When trying to install gnome-media I needed to install gstreamer-plugins-devel
because it needs libgstgconf-0.5.so.1. This seems odd as gnome-media is not per
see a devel package. 
I would expect that gstreamer-plugins would be enough.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.make sure gnome-media and all gstreamer rpms are uninstalled.
2.Then: rpm -i gnome-media-2.1.3-3.i386.rpm

    

Actual Results:  error: Failed dependencies:
        libgstgconf-0.5.so.1 is needed by gnome-media-2.1.3-3
    Suggested resolutions:
        gstreamer-plugins-devel-0.5.0-15.i386.rpm


Expected Results:  gstreamer-plugins should be enough.

Additional info:

I guess the libgstgconf library must be moved from gstreamer-plugins-devel to
gstreamer-plugins, of gnome-media must be changed to live without this library.

Comment 1 Bill Nottingham 2003-01-01 04:22:51 UTC
Jonathan - didn't we fix this after the beta?

Comment 2 Bill Nottingham 2003-02-09 04:59:54 UTC
Fixed in 0.6.0-4.