Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80507

Summary: gnome-sound-recorder hangs
Product: [Retired] Red Hat Linux Reporter: Marius Andreiana <marius.andreiana>
Component: gnome-mediaAssignee: Colin Walters <walters>
Status: CLOSED DUPLICATE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: adamallen, adam, dparsavand, elwoo, srevivo, wtogami
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Marius Andreiana 2002-12-27 14:43:26 UTC
Press Record on toolbar.
Now Play is enabled and Stop is disabled ( should be the other way ).

After trying another action the application frozens.

Comment 1 Warren Togami 2002-12-28 00:49:05 UTC
What sound card is this?  What kernel module?

Does recording work in any other application?


Comment 2 Marius Andreiana 2002-12-29 12:54:11 UTC
soundcard: Creative 128 PCI.

I haven't tried other applications, but 
cat /dev/dsp > test.raw 
and
cat test.raw > /dev/dsp
works.

I couldn't record with gnome-sound-recorder in gnome 2.0 too, but I hoped
gstreamer will fix the problem.

Comment 3 Havoc Pennington 2003-01-13 02:47:09 UTC
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103279


Comment 4 Havoc Pennington 2003-01-19 15:54:39 UTC
*** Bug 82036 has been marked as a duplicate of this bug. ***

Comment 5 Havoc Pennington 2003-01-19 16:15:50 UTC
Reopening for tracking.

Comment 6 Elton Woo 2003-02-09 00:04:29 UTC
Sound card: Creative Labs Ensoniq 64 (ES1371), [Audio PCI-97, Rev. 08] PCI card.
I know the card is woking. If I connect my portable SW/AM/FM radio from its earphone
plug to either 'line-in" or "mic-in", I get sound through my speakers. However,
starting
"record" the slider *DOESN'T* move, though the application says: " recording"....

File Information reports a file size, but when I select "save as" the sound
recorder hangs
with the mouse hourglass pointer ...OR  I get an "untitled.wav file of 0 bytes.
 I've also
tried recording with two different stereo microphones (one from an old recordable 
Sony Walkman, and the other from a recordable Aiwa portable cassette 'walkman').
Perhaps I need a self-powered microphone?

Given that I can hear sounds through my speakers when the recording source is my
radio, shouldn't that create  / save a sound file?

Comment 7 Colin Walters 2004-07-26 17:34:14 UTC
I can reproduce this too.  I'm going to go ahead and consolidate this
with bug 100774, the general "gnome-sound-recorder is still busted" bug.

This bug was originally opened against RH9 - could people try against
the FC2 version, and followup to 100774?

*** This bug has been marked as a duplicate of 100774 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:50:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.