Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 805

Summary: genhdlist coredumps when RPMS directory contains non-RPMs
Product: [Retired] Red Hat Linux Reporter: hag
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: hag
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-01-12 21:54:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description hag 1999-01-12 21:46:55 UTC
genhdlist (part of the installation tools source) will core
dump if the RedHat/RPMS directory contains files that are
not RPMs.  This is due to a failure to check a return status
from rpmlib at one point in genhdlist.  Patch to follow.

Comment 1 David Lawrence 1999-01-12 21:54:59 UTC
This has been fixed for next release. Patched source code can be
accessed at http://www.redhat.com/~msw/code