Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80468

Summary: add NoDisplay support to gnome menus
Product: [Retired] Red Hat Linux Reporter: louisgtwo
Component: gnome-vfs2Assignee: David Zeuthen <davidz>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: hp, jrb, leonard-rh-bugzilla, mclasen, than
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-22 04:16:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description louisgtwo 2002-12-26 23:23:05 UTC
the .desktop file has the wrong categories so it shows up under Extras/Other in
the gnome menu.

Comment 1 louisgtwo 2002-12-30 20:11:29 UTC
redhat-install-packages.desktop has no catagories.

Comment 2 Jeremy Katz 2002-12-31 07:45:26 UTC
Havoc, Than --

This desktop file exists because (from what I understand -- I didn't add it)
it's needed so that konqueror can launch redhat-install-packages when you select
packages and say to install them.  It's not ever an app that's meant to be
called without any packages as arguments.  So what should I do here?

Comment 3 Ngo Than 2003-01-03 11:38:43 UTC
you have to add NoDisplay=true into redhat-config-packages.desktop.
KDE menu will not display it.


Comment 4 Ngo Than 2003-01-03 13:03:49 UTC
It's fixed in CVS. Jeremy, please checkout from CVS ;-)

Comment 5 Jeremy Katz 2003-01-03 15:44:51 UTC
Okay, will be fixed in 1.1.4-1.  Thanks Than.

Comment 6 louisgtwo 2003-01-04 03:05:43 UTC
Seems not to work in gnome though.

Comment 7 Havoc Pennington 2003-01-04 03:29:16 UTC
Yeah gnome doesn't do NoDisplay because it only uses .desktop files for menus.

Comment 8 Matthias Clasen 2005-04-22 04:16:52 UTC
The new menu-spec implementation in gnome-menus supports NoDisplay