Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80444

Summary: build fails with CONFIG_DEVFS_FS
Product: [Retired] Red Hat Linux Reporter: Bernie Innocenti <bernie+fedora>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-11 13:29:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bernie Innocenti 2002-12-26 17:36:11 UTC
Building with devfs fails because of an error in fs/devfs/base.c: 
in function is_devfsd_or_child(), the conditional code should be 
erased or commented away because RH kernel already includes 
the patch which removes the p_opptr field from task_struct.

Comment 1 Bernie Innocenti 2003-04-02 17:38:19 UTC
The bug is still present in 2.4.20-8 shipped with RedHat 9. 

Comment 2 Arjan van de Ven 2003-04-11 13:29:27 UTC
devfs doesn't work in RHL and is turned off as a result.