Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80385

Summary: install leaved empty /etc/hosts file
Product: [Retired] Red Hat Public Beta Reporter: Need Real Name <grover>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: medium    
Version: phoebeCC: grover, noa-bugzilla-redhat, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-28 05:51:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Need Real Name 2002-12-25 16:40:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Text mode install failed to create entries in the /etc/hosts file.  I did assign
a hostname during the install.

Contents of /etc/hosts:

# Do not remove the following line, or various programs
# that require network functionality will fail.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Do a normal CD/text-mode install
2. Cat /etc/hosts
3.
    

Actual Results:  No entries in /etc/hosts

Expected Results:  Installer should at least add a "localhost" entry to
/etc/hosts, and should also include a hostname if one is assigned during the
install.

Additional info:

I've marked this as "high" severity because the desktop (gnome, at least) won't
run properly without a working /etc/hosts file.  This could be a very confusing
problem for a new user.

Comment 1 Warren Togami 2002-12-25 20:59:22 UTC
Was it blank immediately after install, booting into "single" mode?

Perhaps related Bug 80357 - redhat-config-network causes /etc/hosts to become blank.

Comment 2 Need Real Name 2002-12-26 16:46:09 UTC
Warren, I'm afraid I can't answer your question, since I didn't look at
/etc/hosts immediately after the install.  Also, I don't remember running
'redhat-config-network', but maybe I did and I forgot about it; so I suppose
this could be the same bug as 80357.

If/when I do another install of this beta, I will check the file right after
installing.



Comment 3 Michael Fulbright 2003-01-03 02:54:26 UTC
Any additional information to add to this report?

Comment 4 Daniel Resare 2003-01-09 19:55:10 UTC
When I did a fresh phoebe install recently I got only two comment lines in
/etc/hosts (Do not remove the following line..) but no entry for localhost.

Text mode install from http, via the pxeboot images

Comment 5 Daniel Resare 2003-01-20 23:40:32 UTC
I don't see this problem with a fresh install of the new Phoebe (8.0.93)


Comment 6 Need Real Name 2003-01-28 00:09:54 UTC
I never got a chance to try re-installing the first phoebe beta (8.0.92), but I
can confirm that I do *not* see this bug on a fresh (nfs) install of phoebe 2
(8.0.93).

Comment 7 Jeremy Katz 2003-01-28 05:51:01 UTC
Okay, closing as fixed then