Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80367

Summary: orinoco_pci not supported by redhat-config-network
Product: [Retired] Red Hat Linux Reporter: Robert de Rooy <rderooy>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
redhat-config-network exception traceback none

Description Robert de Rooy 2002-12-25 04:30:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
My ThinkPad T30 has an integrated wireless minipci adapter that works under
linux with the orinoco_pci module.
The problem is that neither anaconca, kudzu or redhat-config-network* appear to
know about orinoco_pci.o while it is present on a standard redhat install.

RH8.0 has the same problem

During installation anaconda finds the integrated ethernet adapter (e100) and
asks for it's configuration but it does not list the minipci wireless adapter.

After install, during boot kudzu does not pick it up.

Running redhat-config-network does not pick it up and the adapter is not  in the
list of adapters. The closest is the Orinoco PCMCIA adapter, but it uses a
different module.

workaround for configuring the adapter is to run redhat-config-network , select
to add an interface, select wireless, select the Orinoco PCMCIA entry from the
list and continue to configure it. After you finished, save your changes and
exit the config program.
edit /etc/modules.conf and change the reference from orinoco_cs to orinoco_pci

[root@tderooy root]# lspci -vs 02:02.0
02:02.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan chipset (rev
01)
        Subsystem: Intel Corp.: Unknown device 2513
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at f8000000 (32-bit, prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2

[root@tderooy root]# lspci -nvs 02:02.0
02:02.0 Class 0280: 1260:3873 (rev 01)
        Subsystem: 8086:2513
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at f8000000 (32-bit, prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install phoebe on a machine with a PCI orinoco adapter
2.
3.
    

Additional info:

Comment 1 Jeremy Katz 2002-12-26 03:54:38 UTC
Wireless network adapters are not supported as an install source.  If they're
not being picked up by kudzu afterwards, that's a slightly different problem
that should be fixed

Comment 2 Robert de Rooy 2002-12-26 21:25:21 UTC
I don't want to use the wireless adapter as an installation source, I would 
like the installation program to give me an option to configure it (static ip 
or dhcp, etc)
If I install redhat on a machine with multiple Ethernet adapters it does allow 
me to configure all of them, so why not a wireless adapter? I understand a 
wireless adapter might require some additional settings like ESSID and WEP 
KEY, but still.

Also, the instructions I gave for configuring an Orinoco PCMCIA adapter and 
then changing the orinoco_cs reference in modules.conf to orinoco_pci has a 
problem, if you try to run redhat-config-network afterwards it crashes with a 
traceback because it does not know orinoco_pci

So this issue needs to be fixed in at least redhat-config-network and possibly 
kudzu and anaconda.

Comment 3 Robert de Rooy 2002-12-27 02:38:36 UTC
Created attachment 88935 [details]
redhat-config-network exception traceback

Here is the exception I get when starting redhat-config-network after changing
orinoco_cs to orinoco_pci in modules.conf as described above.

Comment 4 Bill Nottingham 2002-12-30 06:08:42 UTC
What does lspci say, so we can match the ID right?

Wireless adapters not being supported in the installer to install from means you
can't configure them in the installer, either.

And the redhat-config-network bug should probably be filed separately (but I
believe it's in bugzilla somewhere.)

Comment 5 Robert de Rooy 2002-12-30 14:08:19 UTC
lspci data is already listed above, both lspci -v and -vn

Comment 6 Bill Nottingham 2002-12-30 20:32:21 UTC
Hm, that's already in the pcitable, so that should be ok.

Oh, the reason it's not detected as an ethernet device is because of the class
(i.e., generic 'network controller'.)

Not sure how to handle this; if we start mapping that class to ethernet devices,
we're almost certainly going to have false positives from odd hardware somewhere.

Comment 7 Robert de Rooy 2003-01-01 03:09:03 UTC
You must already support different PCI classes of network adapters like 
Ethernet and Token Ring? Would it be so difficult to add another?

PCI Wireless adapters will just become more common. Most ThinkPad's sold these 
days have integrated MiniPCI wireless adapters and I am sure other 
manufacturers are doing the same.

Comment 8 Bill Nottingham 2003-01-01 03:12:51 UTC
'Network controller' is the *base* PCI class. Ethernet and token ring are
subdivisions of that. Treating anything marked as 'network controller' as
ethernet-ish devices will lead to false positives on WAN cards and other
miscellaneous PCI cards.

Comment 9 Robert de Rooy 2003-01-08 17:29:48 UTC
If at the very least orinoco_pci can be added to redhat-config-network so you 
can select it from the dropdown list. That should not require any changes to 
PCI class code and makes it at least a little bit easier to configure these 
PCI wireless adapters.

Comment 10 Harald Hoyer 2003-01-09 10:36:16 UTC

*** This bug has been marked as a duplicate of 80343 ***

Comment 11 Red Hat Bugzilla 2006-02-21 18:50:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.