Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80366

Summary: ThinkPad T30: ACPI errors on boot
Product: [Retired] Red Hat Linux Reporter: Robert de Rooy <rderooy>
Component: kernelAssignee: Jeff Garzik <jgarzik>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: lee, peterm
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Robert de Rooy 2002-12-25 04:08:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
dmesg shows the following ACPI errors during boot, and after install the power
button does not trigger a shutdown (and no messages related to it in the logs
either).

ACPI: Core Subsystem version [20021205]
    ACPI-0263: *** Info: GPE Block0 defined as GPE0 to GPE15
    ACPI-0263: *** Info: GPE Block1 defined as GPE16 to GPE31
    ACPI-1103: *** Error: Method execution failed [\_SB_.PCI0.LPC_.FDC_._INI]
(Node c2f7ff80), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__._INI]
(Node c2f86400), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed
[\_SB_.PCI0.LPC_.EC__.BAT0._STA] (Node c2f86c20), AE_NOT_EXIST
    ACPI-0080: *** Error: Method execution failed
[\_SB_.PCI0.LPC_.EC__.BAT0._STA] (Node c2f86c20), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed
[\_SB_.PCI0.LPC_.EC__.BAT1._STA] (Node c2f86da0), AE_NOT_EXIST
    ACPI-0080: *** Error: Method execution failed
[\_SB_.PCI0.LPC_.EC__.BAT1._STA] (Node c2f86da0), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BGID]
(Node c2f7fe40), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BINI]
(Node c2f7fe20), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BSTA]
(Node c2f7fde0), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed
[\_SB_.PCI0.IDE0.SCND.MSTR._STA] (Node c2f7ff20), AE_NOT_EXIST
    ACPI-0080: *** Error: Method execution failed
[\_SB_.PCI0.IDE0.SCND.MSTR._STA] (Node c2f7ff20), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BGID]
(Node c2f7fe40), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BINI]
(Node c2f7fe20), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BSTA]
(Node c2f7fde0), AE_NOT_EXIST
    ACPI-1103: *** Error: Method execution failed
[\_SB_.PCI0.USB0.URTH.UNST._STA] (Node c2f7f900), AE_NOT_EXIST
    ACPI-0080: *** Error: Method execution failed
[\_SB_.PCI0.USB0.URTH.UNST._STA] (Node c2f7f900), AE_NOT_EXIST
ACPI: Subsystem enabled

release notes say to run /usr/sbin/dmidecode and /usr/sbin/acpidmp but neither
exist, and it does not say which rpm package contains them.

I had a version of dmidecode 1.8 as shipped with lm_sensors-2.7.0 on another
system compiled on RH8.0 and it gives the following:

# dmidecode 1.8
SMBIOS 2.31 present.
DMI 2.31 present.
48 structures occupying 1636 bytes.
DMI table at 0x2FF7C000.
dmi: read: Unexpected end of file
BIOS32 Service Directory present.
        Calling Interface Address: 0x000FD7E0
ACPI 2.0 present.
        OEM ID: IBM
RSD table at 0x2FF6F370.
PNP 1.0 present.
        Event Notification: Polling
        Event Notification Flag Address: 0x000004B4
        Real Mode Code Address: F000:9D36
        Real Mode Data Address: 0040:0000
        Protected Mode Code Address: 0x000F9D54
        Protected Mode Data Address: 0x00000400
PCI Interrupt Routing 1.0 present.
        Table Size: 256 bytes
        Router ID: 00:1f.0
        Exclusive IRQs: None
        Compatible Router: 8086:122e

The minimal output is because it is failing to parse the dmi table.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot system with default phoebe kernel on a ThinkPad T30
2.
3.
    

Additional info:

IBM ThinkPad T30 (2366-52U)
 - P4 1.8GHz, 768MB RAM, 40GB HD
 - ATI Radeon Mobility 7500 w/16MB on a 1400x1050 LCD.

Comment 1 Robert de Rooy 2002-12-27 03:05:29 UTC
dispite the ACPI errors on boot, I can load most of the ACPI ospm_* modules.

modprobe ospm_busmgr
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.PUBS._STA] (Node c2f86520), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BAT0._STA] (Node c2f86c20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-0080: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BAT0._STA] (Node c2f86c20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BAT0._STA] (Node c2f86c20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BAT1._STA] (Node c2f86da0), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-0080: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BAT1._STA] (Node c2f86da0), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BAT1._STA] (Node c2f86da0), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BGID] (Node c2f7fe40), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BINI] (Node c2f7fe20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BSTA] (Node c2f7fde0), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.IDE0.SCND.MSTR._STA] (Node c2f7ff20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-0080: *** Error: Method execution
failed [\_SB_.PCI0.IDE0.SCND.MSTR._STA] (Node c2f7ff20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BGID] (Node c2f7fe40), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BINI] (Node c2f7fe20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BSTA] (Node c2f7fde0), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.IDE0.SCND.MSTR._STA] (Node c2f7ff20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BGID] (Node c2f7fe40), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BINI] (Node c2f7fe20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BSTA] (Node c2f7fde0), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.USB0.URTH.UNST._STA] (Node c2f7f900), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-0080: *** Error: Method execution
failed [\_SB_.PCI0.USB0.URTH.UNST._STA] (Node c2f7f900), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BGID] (Node c2f7fe40), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BINI] (Node c2f7fe20), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.LPC_.EC__.BSTA] (Node c2f7fde0), AE_NOT_EXIST
Dec 26 21:49:11 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_SB_.PCI0.USB0.URTH.UNST._STA] (Node c2f7f900), AE_NOT_EXIST

modprobe ospm_system
Dec 26 21:52:12 localhost kernel: ACPI: System firmware supports S0 S3 S4 S5

modprobe ospm_processor
Dec 26 21:53:15 localhost kernel: Processor[0]: C0 C1 C2 C3, 8 throttling states

modprobe ospm_thermal
Dec 26 21:54:13 localhost kernel:     ACPI-1103: *** Error: Method execution
failed [\_TZ_.THM0._TMP] (Node c2f7eb80), AE_NOT_EXIST

modprobe ospm_ec
Dec 26 21:54:58 localhost kernel: EC: found, GPE 28

modprobe ospm_battery
/lib/modules/2.4.20-2.2/kernel/drivers/acpi/ospm/battery/ospm_battery.o.gz:
init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-2.2/kernel/drivers/acpi/ospm/battery/ospm_battery.o.gz:
insmod
/lib/modules/2.4.20-2.2/kernel/drivers/acpi/ospm/battery/ospm_battery.o.gz failed
/lib/modules/2.4.20-2.2/kernel/drivers/acpi/ospm/battery/ospm_battery.o.gz:
insmod ospm_battery failed

modprobe ospm_ac_adapter
Dec 26 21:56:23 localhost kernel: ACPI: AC Adapter found

modprobe ospm_button
Dec 26 21:57:11 localhost kernel: ACPI: Power Button (FF) found
Dec 26 21:57:11 localhost kernel: ACPI: Sleep Button (CM) found
Dec 26 21:57:11 localhost kernel: ACPI: Lid Switch (CM) found

with ospm_button loaded I can cat /proc/acpi/event and press the lid button and get
button lid 00000080 00000000
button lid 00000080 00000000
and pressing Fn-F4 (sleep) I get
button sleep 00000080 00000000
but pressing the power button does notting

Comment 2 Bill Nottingham 2003-01-01 06:18:49 UTC
*** Bug 80749 has been marked as a duplicate of this bug. ***

Comment 3 Lee Colleton 2003-01-02 21:10:02 UTC
Pressing the <Fn> key will result in a copious repeating error message:
 
ACPI-1103: *** Error: Method execution failed [\_GPE._L18] (Node c3667de0),
AE_NOT_EXIST
ACPI-0572: *** Error: AE_NOT_EXIST while evaluating method [_L18] for GPE[18]

followed by what appears to be a kernel panic.

The system is an IBM Thinkpad X30 (2672)
1.2 GHz Pentium III with 1024 MB RAM

Comment 4 Robert de Rooy 2003-01-02 21:46:09 UTC
I have not seen any ACPI errors (or panics) when pressing the Fn key on my 
T30, just some keymap warnings that they key is undefined.

Comment 5 Jeff Garzik 2003-01-17 21:25:23 UTC

*** This bug has been marked as a duplicate of 82123 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:50:33 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.