Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80309

Summary: gpm causes X PS/2 mouse erratic behavior
Product: [Retired] Red Hat Public Beta Reporter: Warren Togami <wtogami>
Component: gpmAssignee: Eido Inoue <havill>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: pam_huntley, p.van.egdom, redhat-bugzilla, root4you, tedkaz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-13 20:19:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Warren Togami 2002-12-24 10:28:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
When I enable gpm, my PS/2 mouse goes somewhat crazy in X.  When I touch my PS/2
touchpad the pointer sometimes jumps around and clicks uncontrollably.  When I
disable gpm the touchpad returns to normal behavior.  It worked fine in Red Hat
7.3 and 8.0.

I configured my mouse as Generic 2 button PS/2 and Generic 3 button PS/2, same
results.  Same results if either gpm or X started and ended first.  If you
disable gpm, mouse works properly again in X.

Sony Vaio FXA-36 laptop
Athlon Palomino 1GHz
VIA KT133A chipset
2 button PS/2 Synaptics touchpad

Version-Release number of selected component (if applicable):
Phoebe XFree86-
Phoebe gpm-1.19.3-24

How reproducible:

Steps to Reproduce:
1. Enable gpm
2. Use touchpad in X

Actual Results:  
Erratic jumping and clicking behavior of mouse pointer.

Expected Results:  
It should follow my commands.

Comment 1 Warren Togami 2002-12-25 07:49:24 UTC
Reproduced this on a completely unrelated VA Linux 1000 dual Pentium3 server.

Comment 2 Peter van Egdom 2002-12-26 08:30:26 UTC
I experienced the same erratic jumpy mouse movement during Anaconda's X &
monitor setup during installation of Phoebe.

Comment 3 Thomas Bludau 2002-12-26 12:53:54 UTC
*** Bug 80406 has been marked as a duplicate of this bug. ***

Comment 4 Ted Kaczmarek 2002-12-28 21:44:21 UTC
*** Bug 80614 has been marked as a duplicate of this bug. ***

Comment 5 Nathan G. Grennan 2002-12-29 03:22:45 UTC
I also experienced some jumpy pointer during the Phoebe installer.

Comment 6 Ward Fenton 2003-01-08 01:20:21 UTC
I'm seeing similar trouble with Rawhide XFree86-, and
gpm-1.19.3-24. I wasn't seeing this behavior with XFree86 from Phoebe.
These problems occur when both gpm and xfree86 are configured for a PS/2
mouse and gpm is active. The result is that really jumpy sometimes frozen
mouse behaviour as described below.
After configuring the system so gpm wouldn't start in run levels 2 and 3,
I wasn't able to recreate the problem after rebooting and returning to X.
Rebooting with a usb mouse added caused kudzu to reconfigure
/etc/sysconfig/mouse and /etc/X11/XF86Config for usb. In this case, I also
had normal smooth mouse behaviour. Switching these two files around to
have both mice active at once caused the bad behaviour in X if I had gpm
running, started something like find /, and tried to wiggle the ps/2 mouse
while dragging a gnome-terminal by its titlebar. Repeating the same steps
with the usb mouse didn't seem to cause trouble.
Finally, with gpm configured to only deal with the usb mouse, and
XF86Config configured for both mice, I wasn't able to reproduce the

Comment 7 Pam Huntley 2003-01-13 18:29:41 UTC
*** Bug 81540 has been marked as a duplicate of this bug. ***

Comment 8 Bill Nottingham 2003-01-13 20:19:36 UTC
Bug in how we were configuring gpm.

gpm-1.19.13-25 changed so the behavior won't happen with how we configure it.