Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80276

Summary: RFE: Finer-grained package selection during update
Product: [Retired] Red Hat Public Beta Reporter: H. Peter Anvin <hpa+redhat>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED WONTFIX QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: katzj, p.van.egdom, wtogami
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-12 17:42:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description H. Peter Anvin 2002-12-23 21:52:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020828

Description of problem:
When choosing "select packages to update" during a system update, it is unclear
what the checkbox actually does.  It would be a lot nicer if one could choose
between three alternatives: UPDATE, LEAVE, and DELETE.  (Say, for example, green
checkmark, blue dash, and red trashcan.)  Being able to delete a package would
be nice especially when space is tight.

If the currently installed version is the same as the current version, the
UPDATE alternative should either be unavailable or indicated as redundant,
perhaps by putting the green checkmark and blue dash within parenthesis.  This
is important, since a missing checkmark right now doesn't explain if it's
missing because the package is already up to date.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade an existing system
2. Choose customize packages

    

Additional info:

Comment 1 Bill Nottingham 2002-12-24 21:18:51 UTC
As for package removal, I'm not sure that package removal is bound in the
installer context.

Comment 2 Michael Fulbright 2002-12-27 15:46:15 UTC
We will consider this request for a future release.