Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80275

Summary: Starting httpd (apache) causes kernel panic
Product: [Retired] Red Hat Public Beta Reporter: Seth Vidal <skvidal>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: alietss, chris.ricker, dale_kosan, edoutreleau, hpa+redhat, jorton, mike, orinjus, pasqualerinaldi, scowles, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-28 08:37:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79578    

Description Seth Vidal 2002-12-23 21:45:24 UTC
Description of problem:
Starting httpd (apache) panics the kernel


Version-Release number of selected component (if applicable):
apache and kernel from phoebe
How reproducible:
everytime

Steps to Reproduce:
1. install system
2. start httpd
3. watch the console
    
Actual results:
system panics and continues to do so for quite some time.

system becomes unresponsive.


Expected results:
apache should start :-D
system should stay up.

Additional info:

Comment 1 Joe Orton 2002-12-24 01:29:41 UTC
Duplicate of private bug 78715.

Comment 2 Mike Chambers 2002-12-24 01:56:09 UTC
You can get a working system with httpd/kernel by deleting/renaming 
the /etc/httpd/conf.d/ssl.conf file.

Comment 3 Need Real Name 2002-12-26 13:51:18 UTC
Hey guys I solve this just rebuilding the SRPMS of the rawhide httpd-2.0.40-14
wich should be the same, I mean is the same, guess, on my phoebe optimized for
i686 and now works great  with the mod_ssl installed. So this make me think a
lot, why just rebuilding the same SRPMS works and with the binaries that cames
with the distribution not...

Comment 4 Mike Chambers 2002-12-26 14:00:04 UTC
Did you already have /etc/httpd/conf.d/ssl.conf renamed or deleted?  If so, 
you need to readd/rename it back to the original name and then give it a try 
and see what happens.

Comment 5 Joe Orton 2002-12-27 11:56:58 UTC
*** Bug 80420 has been marked as a duplicate of this bug. ***

Comment 6 Joe Orton 2002-12-27 11:57:58 UTC
*** Bug 80422 has been marked as a duplicate of this bug. ***

Comment 7 Joe Orton 2002-12-27 11:59:13 UTC
*** Bug 80419 has been marked as a duplicate of this bug. ***

Comment 8 Joe Orton 2002-12-28 08:37:17 UTC
------- Additional Comments From mingo@redhat.com  2002-12-28 03:24 -------
ok, found and fixed the bug, it should show up in the next rawhide kernel.
A single-line backporting bug caused the semaphore-undo structure to be freed
but not cleared in the task structure, which caused the apparent memory
corruption symptoms.


Comment 9 Joe Orton 2002-12-29 15:12:37 UTC
*** Bug 80638 has been marked as a duplicate of this bug. ***

Comment 10 Bill Nottingham 2003-01-01 03:56:05 UTC
*** Bug 80486 has been marked as a duplicate of this bug. ***

Comment 11 Bill Nottingham 2003-01-03 02:09:31 UTC
*** Bug 80990 has been marked as a duplicate of this bug. ***

Comment 12 Ben Weintraub 2003-01-04 07:26:15 UTC
*** Bug 81093 has been marked as a duplicate of this bug. ***

Comment 13 Mike Chambers 2003-01-07 23:59:53 UTC
Which kernel version is this suppose to be fixed in?  The one in rawhide is 
dated 12/20 and I *think* I tested with that kernel and it wasn't fixed.

Comment 14 Bill Nottingham 2003-01-08 05:24:39 UTC
*** Bug 81303 has been marked as a duplicate of this bug. ***

Comment 15 Joe Orton 2003-01-16 16:17:03 UTC
*** Bug 81248 has been marked as a duplicate of this bug. ***

Comment 16 Mike Chambers 2003-01-23 15:59:32 UTC
Seems to work with Phoebe-2 now.