Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8026

Summary: AHA1542 Not recognized when IDE drives are present
Product: [Retired] Red Hat Linux Reporter: Abraham Bloom <abraham>
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: abraham, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-10 03:02:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Abraham Bloom 1999-12-28 16:28:54 UTC
I have 2 EIDE hard drives, 1 IDE CD/RW,  1 SCSI hard disk id 0, 1 SCSI
cdrom, 1 scsi Tape drive and an ADAPTEC 1542cf controller.   Motherboard is
an ASUS P4 ( I think) with Pentinum II 300 mhz and 64 megs ram.  I have
tried the update disks and tried passing parmeters to boot

Installing 6.1 ( or update )

linux aha1542=0x330

It never sees my SCSI drives, never asks if I have scsi drives, Registers
taht I have a RAID ( which I do not )

Tried same setup with RH 6.0  and everything gets seen properly.

This is by far the worse upgrade I have ever tried.  Even when I force a
load on to the ide ( ignore the fact that my swap is on my scsi drive and
other information is needed from that drive ).  The system does not seem to
perform well and is subject to random hangs.  I have tried several times to
recompile the kernel to get scsi support in and so far I have not had any
luck.   I rolled back to 6.0!    I am looking at TurboLinux and Corel linux
as possible alternatives!    At least when I ran slackware, it always had a
boot disk that recognized my hardware for installation and the kernel
always recompiled easily.

I am not a HAPPY CAMPER!

Abraham Bloom - abraham@clark.net

Comment 1 Jay Turner 2000-02-10 03:02:59 UTC
The prompt for ISA SCSI adapters is only shown automatically if there are not
other devices available for the installation.  Since you have IDE drives, the
installer does not prompt for anything else.  This is to simplify the installer
for people that have no clue whether they have a SCSI adapter or not.  Anyway,
the way around this, for people that know they have ISA adapters, is to boot the
installer in expert mode by typing "linux expert" at the boot prompt.