Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80208

Summary: choice of NVidia GeForce2 card overridden
Product: [Retired] Red Hat Public Beta Reporter: Alexandre Oliva <aoliva>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebe   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-22 05:06:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79578    

Description Alexandre Oliva 2002-12-22 09:42:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I told the installer that the video card of my laptop is NVidia GeForce2, even
though it's a 2Go, because the option for the 2Go was missing.  Still, GeForce2
is supposed to use the `nvĀ“ driver, but anaconda generated a XF86Config file
that used the vesa driver, that didn't support the resolution I had chosen.  I
don't think it should override the user's choice.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install on a laptop with a NVidia GeForce2 Go card
2.Choose NVidia GeForce2 as the video card


Actual Results:  XF86Config uses the VESA driver.

Expected Results:  It should use the nv driver, that is the correct driver for
the video card I specified, and I know it works on GeForce2 Go now.  If
r-c-xfree86 uses the nv driver when told to use it, why shouldn't anaconda?

Additional info:

It would be nice to have the option of GeForce2 Go in the installer, ideally
auto-detected, and it can default to the nv driver now, since it actually works.

Comment 1 Jeremy Katz 2002-12-24 03:35:33 UTC
Back to anaconda and mike... although this is in rhpl, it'll be tracked better
as anaconda

Comment 2 Alexandre Oliva 2003-01-22 05:06:33 UTC
Confirmed fixed in phoebe2.  The spelling is a bit odd, since it's nVidia
instead of NVIDIA like all others, but detection works and the setting is obeyed.