Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80153

Summary: 'neat' crashed, line 774, update_devicelist
Product: [Retired] Red Hat Linux Reporter: bennie smith <bennies>
Component: internet-configAssignee: Ngo Than <than>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description bennie smith 2002-12-20 19:54:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
(This might go in you netcfg category.  There was no category for 'neat', the
app that crashed.)
Red Hat 8.0, Bluecurve (based on Gnome I guess), KDE is NOT installed.
There is no elegant way to connect to the internet via PPP with a 56K modem, so
went to Internet Configuration Wizzard and set up ppp0.  Then opened System
Settings/Network.  Have to enter Root password.  Then select ppp0. Activate. 
Dialing happens. Connection made.  Then there's no way to tell how fast you
connect or to see the status of your connection.

Then after a few minutes, this happens:

Traceback (most recent call last):
  File "/usr/sbin/neat", line 774, in update_devicelist
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
63, in __init__
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
66, in load
OSError: Too many open files

The only things Open are neat, mozilla, and yahoo.  And 2 terminal sessions,
with nothing running in them.

The connection stays alive, but now there's no way to disconnect except to kill
the pppd process.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. System Settings/Network
2. Activate ppp0
3. Wait for error
    

Actual Results:  neat crashed as explained above.

Traceback (most recent call last):
  File "/usr/sbin/neat", line 774, in update_devicelist
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
63, in __init__
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
66, in load
OSError: Too many open files

Additional info:

Sure do miss rp3 with the little visual activity graph and an indication  of
download speed.

Comment 1 Ngo Than 2002-12-21 22:13:32 UTC

*** This bug has been marked as a duplicate of 80154 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.