Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80081

Summary: clurmtabd doesn't sync export subdirectories
Product: Red Hat Enterprise Linux 2.1 Reporter: Lon Hohberger <lhh>
Component: clumanagerAssignee: Lon Hohberger <lhh>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: high    
Version: 2.1CC: ckloiber, strong, tao, vincent_valdez
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-13 23:17:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Lon Hohberger 2002-12-19 18:34:46 UTC
Description of problem:
If a service is specified with a given NFS export:

/export

and an authorized client mounts:

/export/dir1

then the /var/lib/nfs/rmtab entry:

client:/export/dir1:0x00000001

does not get synchronized across the cluster, causing ESTALE in the event of
fail-over or manual relocation.

Version-Release:    1.0.16-7
How reproducible:   Always

Steps to Reproduce:
1. Create a clumanager service with an NFS export "/export", available to world
(*) with any mount options.
2. Create a directory "/export/dir1"
3. Mount the NFS mount "/export/dir1" on any authorized client.
4. Power-cycle the active cluster server.
    
Actual results:
Client which has /export/dir1 mounted receives ESTALE, even if it also has
/export mounted (for which, it does NOT receive ESTALE!).

Expected results:
Seamless transition.

Comment 1 Lon Hohberger 2002-12-20 13:57:18 UTC
Have a fix for this and memory consumption.  Ironing out bugs.

Comment 2 Lon Hohberger 2002-12-20 16:40:05 UTC
Testing mostly done.  The build has these features:

- Performance an order of magnitude faster (was testing merges/reads/syncs on
your 13K-line file plus my 4K-line file).
- Memory consumption (while using just the 13K-line file) is about 10% of what
it was.
- Subdirectories sync properly.


Comment 3 Lon Hohberger 2002-12-20 19:35:14 UTC
Fix in pool.  Test away!

Comment 4 Lon Hohberger 2002-12-20 19:36:57 UTC
Wrong status field; hours updated.

Comment 5 Jim Strong 2002-12-23 16:38:39 UTC
We have been running with clumanager-1.0.19-1suny.i386.rpm in place for about 60
hours now, 4 NFS servers, 2000 clients, active/active with multiple exports per
service, and this seems to work fine at this point.  Service start/stop/relocate
is fast, and no ESTALE on server failure or manual service relocate.
Thanks!

Comment 6 John Flanagan 2003-02-13 23:17:27 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-314.html