Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80024

Summary: 2-byte fonts don't render
Product: [Retired] Red Hat Linux Reporter: Christopher Hicks <chicks>
Component: gimpAssignee: Matt Wilson <msw>
Status: CLOSED DEFERRED QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-19 05:54:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Christopher Hicks 2002-12-18 22:02:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Fonts that render correctly in gnome-font-properties break in gimp.
Problem fonts includes those from the RH73 ttfonts-1.0-9 rpm.

Version-Release number of selected component (if applicable): 1.2.3


How reproducible:
Always

Steps to Reproduce:
1. Make sure ttfonts-1.0-9.noarch.rpm is installed
2. Start gimp
3. Create a new image.
4. Pick the font tool and click in the new image
5. Pick arioso
6. Click ok

Actual Results:  Font renders in a tiny fixed-point font like the Windows System
font.

Expected Results:  The font to render correctly.

Additional info:

When this happens a message comes up saying "This is a 2-byte font and may not
display correctly."  I can't find anything to explain what this means.

I've searched the web, and several bugzillas trying to find a solution to this,
but it is causing a lot of irritation within our design staff and it's happening
with lots of ttf fonts, not just arioso.  I'd appreciate any pointers,
workarounds, or clues that anyone has.

Comment 1 Matt Wilson 2002-12-19 05:54:22 UTC
this is because GIMP 1.2.3 is a GTK+ 1.2 application, whereas
gnome-font-properties is a GTK+ 2.0 application that uses fontconfig and pango
for font configuration and rendering.  Until GIMP 1.4 is complete you'll
continue to have this kind of problem.