Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7995

Summary: gnats 3.110 seems to be broken
Product: [Retired] Red Hat Powertools Reporter: Alexander L. Belikoff <abel>
Component: gnatsAssignee: Tim Powers <timp>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-13 15:21:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexander L. Belikoff 1999-12-25 22:47:01 UTC
I've just tried to upgrade my old gnats installation with 3.110 from the RH
6.1 PowerTools CD. Here go the problems:

1. If /usr/share/gnats is not present, gnats-3...rpm installation fails
with 'script failed' message. This is because it tries to create a user
with an unexistant parent of home directory.

2. User 'gnats' has a file listed as it's home directory (.../config) - the
last component must be eliminated.

3. Gen-index segfaults

4. query-pr doesn't find any PRs because the old index is not compatible
with the new format.

Once the beta FTP site is back, I'll upload the fixed spec file that builds
GNATS 3.113. The latter seems to work fine.

Comment 1 Tim Powers 1999-12-27 15:18:59 UTC
Can you send me the spec file? If you can't send it thorugh bugzilla or don't
want to, please send it to timp@redhat.com so that I can build it and at least
get it out to rawhide.

Tim

Comment 2 Tim Powers 2000-01-13 01:33:59 UTC
I am closing this because there hasn't been any response since my last message.
You can reopen this bug in the future.

Tim

Comment 3 Tim Powers 2000-01-13 15:20:59 UTC
Ughhh. I have no idea what happened to the spec you sent origionally. Weird.
Anyway, I have incorporated your spec, look for it in rawhide.

Tim