Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79866

Summary: RFE: utemper needs documentation
Product: [Retired] Red Hat Linux Reporter: Patrick C. F. Ernzer <pcfe>
Component: utempterAssignee: Mike A. Harris <mharris>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: mitr
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-28 00:52:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Patrick C. F. Ernzer 2002-12-17 17:09:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
utemper only contains the GPL as documentation. We should really include a small
blurp explaining what it does and/or a man page.

Version-Release number of selected component (if applicable):
0.5.2-10

How reproducible:
Always

Steps to Reproduce:
1. wonder why /var/log/wtmp is gid utmp
2. read rc.sysinit
3. finally find /usr/sbin/utempter
4. look at /usr/sbin/utempter
5. as this is a compiled binary, having a quick look is not an option

Actual Results:  no docs available

Expected Results:  documentation available

Additional info:

A customer's security scanner triggered on the gid of /var/log/wtmp, so
documentation will help customers tripping over this in the future.

Comment 1 Mike A. Harris 2002-12-18 19:25:29 UTC
Reassigning to "distribution" component as I don't see a "documentation"
component.  In general I don't believe we write manpages for things like
this, however someone might, so I've reassigned it in case the documentation
folk are interested.

Comment 2 Bill Nottingham 2002-12-18 21:24:12 UTC
For things we write, documenting falls on us. It's generally a low priority
thing, but it stays with the package. Docs usually doesn't write man pages as much.

Comment 3 Mike A. Harris 2002-12-18 21:44:56 UTC
Ah ok.  Well, to be quite honest, I've got plenty of much higher priority
bug reports to attend to, and maintaining X, I am most likely always going
to have higher priority bugs.  XFree86 is missing many many manpages itself
which don't get done due to serious problems.

So I am extremely unlikely to ever write documentation for utempter.  The
package just sort of fell on me rather than being authored by me.

If someone feels like writing documentation for it, and attaching it to this
bug report, I'd be glad to have a look and probably include it.  But again,
I've got bigger fish to fry right now at least, so I'm deferring this.



Comment 4 Mike A. Harris 2005-09-28 00:52:03 UTC
Closing WONTFIX, as the likelyhood of this ever being higher than
"very low priority" is very slim, as is the likelyhood of me ever
clearing the list of all higher priority items.

If someone writes documentation for utempter and attaches it in
the future, we can patch the package with it in a future OS
release.