Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79723

Summary: gnome-terminal consumes all memory
Product: [Retired] Red Hat Linux Reporter: John Newbigin <jn>
Component: XftAssignee: Owen Taylor <otaylor>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Newbigin 2002-12-16 06:38:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
quite frequently, gnome-terminal starts consuming memory, causing the machine to
start grinding the swap and running like a dog.  If you can manage to switch
back to the console and run top, gnome-terminal is using over 600M of ram.  Some
time later, gnome terminal dies, along with any children.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.run gnome-terminal
2.wait
    

Actual Results:  gnome-terminal dies.  I don't know if it dies it's self or
something (the kernel) kills it.

Expected Results:  gnome-terminal can run forever with no memory leaks.

Additional info:

The problem does not seem to be triggered by the user.  When I was using an X
application launched from gnome-terminal, it started and killed not only
gnome-terminal but the app I was using :(

Comment 1 Havoc Pennington 2002-12-16 18:30:53 UTC
All Xft apps (GTK2 or Qt3) do this if you don't have RENDER extension 
for your X server.

Try the test fix packages at ftp://people.redhat.com/hp/testing/

Comment 2 Owen Taylor 2003-01-07 20:48:30 UTC

*** This bug has been marked as a duplicate of 76219 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:21 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.