Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79684

Summary: Unable to mount USB cdrom burner
Product: [Retired] Red Hat Linux Reporter: Steve Bangert <sbangert>
Component: kernelAssignee: Pete Zaitcev <zaitcev>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-03 18:10:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
output of dmesg with USB storage debug enabled
none
patch transport.c and .h
none
usb storage patch none

Description Steve Bangert 2002-12-15 01:24:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.20-rmap15b i586)

Description of problem:
I've got a Sony Spressa cdrom burner model #CRX100E/X that worked fine under
RH-7.1 and RH-7.2 (except for a problem with the scsi-cdrom module failing to
load on boot about two thirds of the time, which required another reboot or two
until the module would finally load) on RH-7.3 and RH-8.0 I am unable to mount
the device and just get
an error " unable to mount device, bad super block, etc,etc" and when using
Xcdroast it fails to recognize any media. I have traced the problem to version
1.44 of transport.c that was first introduced in kernel 2.4.19-pre3 and then
backported to the RH-2.4.18.xxx kernels. All vanilla kernels 2.4.19-pre2 and
older work fine!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.plug-in cdrom, turn it on
2.boot RH-7.3
3.try to mount USB CDROM
    

Actual Results:  unable to mount USB cdrom

Expected Results:  should be able to mount device, Xcdroast shpould be able to
recognize cdrom media

Additional info:

problem started with version 1.44 of transport.c or 1.17 of transport.h

Comment 1 Steve Bangert 2002-12-15 01:34:07 UTC
Created attachment 88737 [details]
output of dmesg with USB storage debug enabled

Comment 2 Steve Bangert 2002-12-15 01:42:20 UTC
Created attachment 88738 [details]
patch transport.c and .h

this is the patch(s) that broke USB storage for me

Comment 3 Steve Bangert 2003-03-06 10:59:00 UTC
Created attachment 90488 [details]
usb storage patch

Comment 4 Steve Bangert 2003-03-06 11:04:18 UTC
Thanks to Alan Stern this matter is solved, see the latest attachment, is there
any chance that this patch could be applied to the latest beta (pheobe) kernel
before RH8.1 is released, this patch should help a lot of people.

Comment 5 Pete Zaitcev 2003-06-03 18:10:24 UTC
2.4.20-18(.[789]) is available today.