Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79651

Summary: Unable to compile i686 kernel
Product: [Retired] Red Hat Linux Reporter: Tim McAuley <mcauleyt>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-26 17:11:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
attempted compile output none

Description Tim McAuley 2002-12-14 16:08:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have been unable to get my Compaq WL200 pci card working and am trying to
rebuild the kernel without pcmcia/cardbus or wireless n/w card support (so I can
use a different pcmcia-cs version and wlan project).

I have updated the kernel to 2.4.18-18-0

The kernel compile fails during the "make" stage.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
- Remove kernel-pcmcia package. (not sure if this affects build or not)

- cd /usr/src/linux-2.4
- make mrproper, make clean, make xconfig.
- Loaded standard i686 kernel config.
- Disabled pcmcia/cardbus support under General
- Disabled wirless n/w card support under n/w devices section.
- Saved config.
- make dep - okay
- make - errors  (see actual results)

Actual Results:  (only the end of the output before the error)

gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686   -nostdinc
-I /usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=pci_i386  -c
-o pci-i386.o pci-i386.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686   -nostdinc
-I /usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=pci_pc  -c
-o pci-pc.o pci-pc.c
{standard input}: Assembler messages:
{standard input}:1037: Warning: indirect lcall without `*'
{standard input}:1113: Warning: indirect lcall without `*'
{standard input}:1198: Warning: indirect lcall without `*'
{standard input}:1280: Warning: indirect lcall without `*'
{standard input}:1295: Warning: indirect lcall without `*'
{standard input}:1305: Warning: indirect lcall without `*'
{standard input}:1374: Warning: indirect lcall without `*'
{standard input}:1389: Warning: indirect lcall without `*'
{standard input}:1400: Warning: indirect lcall without `*'
{standard input}:1867: Warning: indirect lcall without `*'
{standard input}:1945: Warning: indirect lcall without `*'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686   -nostdinc
-I /usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=pci_irq  -c
-o pci-irq.o pci-irq.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686   -nostdinc
-I /usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=mtrr 
-DEXPORT_SYMTAB -c mtrr.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686   -nostdinc
-I /usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=apm 
-DEXPORT_SYMTAB -c apm.c
apm.c: In function `apm_cpu_idle':
apm.c:854: warning: deprecated use of label at end of compound statement
{standard input}: Assembler messages:
{standard input}:244: Warning: indirect lcall without `*'
{standard input}:339: Warning: indirect lcall without `*'
rm -f kernel.o
ld -m elf_i386  -r -o kernel.o process.o semaphore.o signal.o entry.o traps.o
irq.o vm86.o ptrace.o i8259.o ioport.o ldt.o setup.o time.o sys_i386.o pci-dma.o
i386_ksyms.o i387.o bluesmoke.o dmi_scan.o pci-i386.o pci-pc.o pci-irq.o mtrr.o
apm.o
gcc -D__ASSEMBLY__ -D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include
-traditional -c head.S -o head.o
gcc: Internal error: Segmentation fault (program tradcpp0)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [head.o] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/arch/i386/kernel'
make: *** [_dir_arch/i386/kernel] Error 2
[root@mothy linux-2.4]#


Additional info:

Machine spec:

Abit be6 motherboard
Celeron 1.1GHz (using appropriate slot 1 convertor)
512MB Ram.

Comment 1 Alan Cox 2002-12-16 02:30:43 UTC
Does it always error the same way in the same place ?


Comment 2 Tim McAuley 2002-12-16 17:48:52 UTC
As far as I remember it does... I will check it out for you in a couple of hours
(at home).

One point I forgot to mention is that I was setting the CPU type to PIII,
Celeron Cuppermine.

I have since tried two other variations (with the same results... how exact I'm
not sure, will check this evening):

1) Standard config - standard CPU config (PII, Celeron) - PCMCIA & wireless disabled
2) Standard config (no changes at all).

Both have failed during "make".





Comment 3 Tim McAuley 2002-12-16 18:40:35 UTC
Created attachment 88761 [details]
attempted compile output

Hmmm... the plot thickens. Some more information for you.

I have just tried to compile the same kernel on a dual PIII 866 in work (using
standard, not smp, i686 config), with similar but not the same results.

I have attached the end results. This may be a completely different bug... but
it is close enough to the last position to raise an eye brow. 

Thanks for all the help.

Tim

Comment 4 Tim McAuley 2002-12-17 23:06:28 UTC
Just to confirm. I do get the same error message (as stated in the first report)
on my home machine (even with standard config with no modifications) every time.

Comment 5 Tim McAuley 2002-12-26 17:11:55 UTC
Downloaded and installed the new Kernel 2.4.18-19.8.0. 

Works like a charm!

Thanks for all the help!

(and as a side... have eventually got my Compaq wl200 wirless card to work!)