Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79623

Summary: Missing Glide3-devel and libpng-devel in BuildRequires
Product: [Retired] Red Hat Raw Hide Reporter: Warren Togami <wtogami>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: low    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-14 04:51:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Warren Togami 2002-12-14 03:08:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Rawhide XFree86-4.2.99.2-0.20021210.0.src.rpm seems to be missing BuildRequires
glide3-devel.

Comment 1 Warren Togami 2002-12-14 03:10:19 UTC
Oops, that should be Glide3-devel.


Comment 2 Warren Togami 2002-12-14 04:19:25 UTC
Seems to be missing libpng-devel too.  Very similar to this report:
http://216.239.39.100/search?q=cache:0uM2Zoco0BIC:www.xfree86.org/pipermail/newbie/2002-October/017911.html+&hl=en&ie=UTF-8

making all in programs/xcursorgen...
make[4]: Entering directory
`/usr/src/redhat/BUILD/XFree86-4.2.99.2/xc/programs/xcursorgen'
gcc -m32 -O2 -march=i386 -mcpu=i686 -fno-strength-reduce -fno-strict-aliasing
-pipe -ansi -pedantic -Wall -Wpointer-arith -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs
-Wundef     -I../.. -I../../exports/include   -Dlinux -D__i386__
-D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE -D_BSD_SOURCE
-D_SVID_SOURCE  -D_GNU_SOURCE   -DFUNCPROTO=15 -DNARROWPROTO       -c -o
xcursorgen.o xcursorgen.c
xcursorgen.c:35:17: png.h: No such file or directory
xcursorgen.c:140: parse error before "png"
xcursorgen.c:141: warning: function declaration isn't a prototype
xcursorgen.c: In function `premultiply_data':
xcursorgen.c:144: `row_info' undeclared (first use in this function)
xcursorgen.c:144: (Each undeclared identifier is reported only once

Comment 3 Mike A. Harris 2002-12-14 04:51:23 UTC
I've now added the libpng-devel, however Glide3-devel is intentionally
not listed as a Buildrequires.  The %prep section of the specfile explains
why.

This is fixed in rawhide 20021210.1 build.