Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79612

Summary: Bad: Passwords with numbers cause crash
Product: [Retired] Red Hat Linux Reporter: Need Real Name <adam>
Component: gftpAssignee: Jonathan Blandford <jrb>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: ddumas
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-07-30 23:08:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Need Real Name 2002-12-13 23:42:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a; MultiZilla
v1.1.22) Gecko/20021213

Description of problem:
When you are connecting to an FTP server, if you use a password that starts with
a number, it causes gFTP to exit abnormally (crash).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run gFTP and login with the apporpiate information to your server.
2. As your password, enter a password that starts with a number.

Actual Results:  The program exits with the error:
/usr/bin/gftp: line 9:  2989 Segmentation fault       /usr/bin/gftp-text

Expected Results:  gFTP should connect to the server appropiately.

Additional info:

Although unchecked, this bug may cause the password to be stored in the memory
and may lead to memory leaks if the information that was stored during the crash
is not cleared.

Comment 1 Havoc Pennington 2002-12-20 02:10:34 UTC
We should confirm still present in latest rawhide gftp.

Comment 2 Elliot Lee 2003-02-24 17:20:45 UTC
Can't reproduce with gftp-2.0.14-2

Comment 3 Bill Nottingham 2003-07-30 23:08:38 UTC
Closing out some bugs that have been in MODIFIED state. Please reopen if they
persist.