Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79541

Summary: esound 0.2.28-1 exits
Product: [Retired] Red Hat Raw Hide Reporter: Need Real Name <donaldlf>
Component: esoundAssignee: Havoc Pennington <hp>
Status: CLOSED DEFERRED QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: alpha   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-11 04:48:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Need Real Name 2002-12-13 07:05:52 UTC
esound 0.2.28-1 (2 errors )

1. the .la libraries not included in the spec file. added ..

*** /usr/src/redhat/SPECS/esound.spec~  2002-08-21 12:41:56.000000000 -0700
--- /usr/src/redhat/SPECS/esound.spec   2002-12-12 00:34:03.000000000 -0800
***************
*** 75,78 ****
--- 75,79 ----
  %{_bindir}/esdsample
  %{_libdir}/*.so.*
+ %{_libdir}/*.la
  
  %files devel


2. THe demon exits when trying to start with NO messages....

[root@shadowdragon mp3]# esd -tcp -public -port 9999
- accepting connections on port 9999
[root@shadowdragon mp3]# esd
[root@shadowdragon mp3]# 

[root@shadowdragon mp3]# which esd
/usr/bin/esd
[root@shadowdragon mp3]# ldd /usr/bin/esd
        libesd.so.0 => /usr/lib/libesd.so.0 (0x0000020000044000)
        libcpml.so => /lib/libcpml.so (0x0000020000060000)
        libaudiofile.so.0 => /usr/lib/libaudiofile.so.0 (0x00000200000ee000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0x000002000012c000)
        libm.so.6.1 => /lib/libm.so.6.1 (0x00000200001c4000)
        libdl.so.2.1 => /lib/libdl.so.2.1 (0x000002000024a000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x000002000025e000)
        libc.so.6.1 => /lib/libc.so.6.1 (0x0000020010000000)
        libots.so => /lib/libots.so (0x00000200002c4000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x0000020000000000)
[root@shadowdragon mp3]# rpm -qf /usr/bin/esd
esound-0.2.28-1

Comment 1 Havoc Pennington 2002-12-13 21:17:07 UTC
The .la files thing is not a bug, they are omitted on purpose. If you 
need them you're doing something wrong (or the package you're using is).

For the daemon startup, try an "strace -f -o /tmp/output esd" and attach 
/tmp/output to this bug, perhaps. It works here. Reopen bug on adding 
attachment.

Comment 2 Need Real Name 2002-12-14 01:04:20 UTC
I agree on the .la files however the rpm build fails. It identifies the two
files as installed but not packaged and exits with an error.

I'll try and get the strace soon.

Leslie

Comment 3 Bill Nottingham 2003-02-11 04:48:01 UTC
Closing, no response.