Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79492

Summary: shell errors from configure script
Product: [Retired] Red Hat Raw Hide Reporter: Tim Waugh <twaugh>
Component: autoconfAssignee: Jens Petersen <petersen>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-16 13:37:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tim Waugh 2002-12-12 12:10:38 UTC
Description of Problem:
A configure.in script, which worked fine in 2.53, is now giving shell errors
when run against autoconf-2.57.

Version-Release number of selected component (if applicable):
autoconf-2.57-1

How Reproducible:
100%

Steps to Reproduce:
1. wget http:://cyberelk.net/tim/data/patchutils/stable/patchutils-0.2.17.tar.bz2
2. tar jxf patchutils-0.2.17-tar.bz2
3. cd patchutils-0.2.17
4. autoconf
5. ./configure

Actual Results:
[...]
config.status: executing depfiles commands
./configure: eval: line 1: unexpected EOF while looking for matching `"'
./configure: eval: line 2: syntax error: unexpected end of file
./configure: eval: line 1: unexpected EOF while looking for matching `"'
./configure: eval: line 2: syntax error: unexpected end of file


Expected Results:
No error messages.

Comment 1 Jens Petersen 2002-12-16 09:00:17 UTC
Works fine with autoconf-2.56 too.  Looks like a potential
new autoconf-2.57 bug.  I'll ask about it upstream.

If there isn't a simple fix, I'll probably revert to 2.56 for
now.

Comment 2 Tim Waugh 2002-12-16 13:37:03 UTC
Oh, wait, I just found this in configure.in:

AC_SUBST(AC_LIBOBJ)

That can't be right.  I took it out and now it works.  Sorry.