Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79423

Summary: tclhelp display breakage
Product: [Retired] Red Hat Linux Reporter: Peter Dalgaard <p.dalgaard>
Component: tcltkAssignee: Jens Petersen <petersen>
Status: CLOSED RAWHIDE QA Contact: Bill Huang <bhuang>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-02-26 06:56:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peter Dalgaard 2002-12-11 16:27:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
In RH8.0, the tclhelp output has garbage in displayed help pages

1mNAME0m
       scale - Create and manipulate scale widgets

1mSYNOPSIS0m
       1mscale 4m22mpathName24m ?4moptions24m?

Looks like color/font changing codes that aren't getting interpreted.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start tclhelp
2.click Tk/Widgets/scale
3.
	

Actual Results:  Garbled help page

Expected Results:  normal help page

Additional info:

Comment 1 Jens Petersen 2002-12-12 06:37:54 UTC
Reproduced also in latest 8.3.5-78.

As you say, looks like escape codes for bold, etc are appearing
the text.

Comment 2 Jens Petersen 2004-02-26 06:56:12 UTC
Fixed in tclx-8.3.5-1 in FC devel.