Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79420

Summary: redhat-config-network fails with a bug trace when I try to add a network adapter
Product: [Retired] Red Hat Linux Reporter: Need Real Name <mike.bauman-1>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-11 15:52:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-12-11 15:52:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-18.7.x i686)

Description of problem:
Please visit http://bugzilla.redhat.com/bugzilla/ !
File a bug against component redhat-config-network. Thank you!

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",
line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 64, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-network (neat)
2.Select hardware tab
3.click add
4.select ethernet and click OK
Fatal Exception occurs

Actual Results:   Please visit http://bugzilla.redhat.com/bugzilla/ !
File a bug against component redhat-config-network. Thank you!

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",
line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 64, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description


Expected Results:  I should have gotten a drop down list of network adapters

Additional info:

Comment 1 Harald Hoyer 2002-12-11 16:25:34 UTC

*** This bug has been marked as a duplicate of 76446 ***