Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79278

Summary: Kudzu repeated adds usb-audio device
Product: [Fedora] Fedora Reporter: Michael Fulbright <msf>
Component: kudzuAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bnocera, rvokal, sehh
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-07-14 19:21:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
kudzu-ignore-lots-speakers.patch none

Description Michael Fulbright 2002-12-09 14:34:03 UTC
Kudzu sees the usb microphone in my logitech quickcam pro 3000 and prompts about
4 times about an 'unknown' soundcard.  If I look in /etc/sysconfig/hwconf it has
the 'unknown' device several times.  Everytime I reboot kudzu asks me about it.

I can bring this in sometime this week if you'd like to look at it.

Comment 1 Bill Nottingham 2002-12-09 17:53:00 UTC
It *probably* has four separate USB audio devices in /proc/bus/usb/devices -
what does that look like?

Comment 2 Bill Nottingham 2002-12-19 20:59:03 UTC
Yes, it does have four 'audio' devices. Currently it's working-as-designed. May
need to come up with a better design. :)

Comment 3 Bill Nottingham 2004-07-12 21:17:25 UTC
*** Bug 127626 has been marked as a duplicate of this bug. ***

Comment 4 Bastien Nocera 2004-07-13 21:51:14 UTC
Created attachment 101872 [details]
kudzu-ignore-lots-speakers.patch

Ignore all the usb devices when the "Alt" (alternate) is > 0.

Comment 5 Bastien Nocera 2004-07-13 21:53:29 UTC
I made this patch following a conversation with Thomas Sailer, the
maintainer of the USB audio stack:

> It shows 7 audio devices being added. Which is consistent with the
> output from /proc/bus/usb/devices[1].

Well, no, there's one device in your devices file whose interface 1 has
7 altsettings, i.e. alternative and mutually exclusive ways to operate
the device.

> I was wondering what are all those audio devices used for, and if it was
> safe for kudzu to "collapse" them all into one.

I don't know why kudzu reports each altsetting separately, sounds like a
kudzu bug to me...

It doesn't quite fix the problem, though:
T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  4 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0471 ProdID=0101 Rev= 1.00
S:  Manufacturer=Philips Electronics
S:  Product=Philips USB Digital Speaker System
C:* #Ifs= 3 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=audio
I:  If#= 1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=audio
I:  If#= 1 Alt= 1 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS=  56 Ivl=1ms
I:  If#= 1 Alt= 2 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 112 Ivl=1ms
I:  If#= 1 Alt= 3 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 112 Ivl=1ms
I:  If#= 1 Alt= 4 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 224 Ivl=1ms
I:  If#= 1 Alt= 5 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 168 Ivl=1ms
I:  If#= 1 Alt= 6 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 336 Ivl=1ms
I:  If#= 2 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid
E:  Ad=83(I) Atr=03(Int.) MxPS=   1 Ivl=10ms

If#=0 and If#=1 both get added. But that's as far as I managed to go
without pulling my hair out more tonight.

Comment 6 Bill Nottingham 2004-07-14 19:21:18 UTC
Added, will be in 1.1.73-1.

Comment 7 Bill Nottingham 2004-07-14 19:21:30 UTC
*** Bug 77178 has been marked as a duplicate of this bug. ***

Comment 8 Dimitris 2004-07-15 00:50:24 UTC
Please note, that the microphone on the USB webcam is loaded
as the FIRST sound card.

Thus many people complain that they loose sound when they boot
with their webcam connected!

This shouldn't happen, if the system has more than one sound
devices, the user should be asked which one will be used primary.

The same problem happens when multiple sound cards are installed.

In order to fix the problem with the USB webcam microphone, this
has to be added in the modprobe.conf:

alias snd-card-0 <your-sound-module>
options <your-sound-module> index=0

alias snd-card-1 snd-usb-audio
options snd-usb-audio index=1

this will make the usb microphone come second, thus not
affect the overall sound output of the system.

btw, we've been reporting this bug since RH8 and RH9, its about time
it gets fixed ;)