Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79221

Summary: mc has problems with the subshell when changing directories
Product: [Retired] Red Hat Linux Reporter: Iustin Pop <iusty>
Component: mcAssignee: Havoc Pennington <hp>
Status: CLOSED CURRENTRELEASE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: al.sh, leonard-rh-bugzilla, mitr, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-08-24 21:33:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
strace output from 'strace -p <pid of mc> -fF -s 250 none

Description Iustin Pop 2002-12-07 22:34:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
mc-4.5.55-12 from RedHat 8.0 exhibits a problem with the subshell which didn't
occur with mc-4.5.51 from RedHat 7.3.

The problem is that at every change of directory, the subshell exists with some
error, after communicatting a lot with the parent mc for every path component of
the new or old (I can't tell) location. This results in a delay of ~1-2 seconds
on deeply nested directories - which is annoying, to say the least. The old mc
didn't produce any delay (on this scale).

Version-Release number of selected component (if applicable):
4.5.55-12

How reproducible:
Always

Steps to Reproduce:
1. start mc
2. go to, for example, /usr/share/doc/ImageMagick-5.4.7/www/Magick++, which is a
path with many entries
3. navigate up/down in the hierarchy, you will see the delay
4. do a strace -fF -s 250 -p <pid> on the mc process, the exit of the child is
visible, after a lot of strange communication with the parent process (mc itself).

Actual Results:  Subshell exists, instead of changing the cwd to the new location.

Expected Results:  Subshell should just change its cwd.

Additional info:

My system is RedHat 8.0 + updates, but with kernel from www.kernel.org + xfs,
and with devfs. A strace will be posted after this bug entry.

Comment 1 Iustin Pop 2002-12-07 22:37:25 UTC
Created attachment 87824 [details]
strace output from 'strace -p <pid of mc> -fF -s 250

Comment 2 Havoc Pennington 2002-12-08 00:16:27 UTC
Try with mc 4.6.0 in rawhide (when it appears on the ftp site, if it hasn't)

Comment 3 Need Real Name 2002-12-24 15:56:13 UTC
I have a similar problem. It seems that the delay disappears when I run mc in non-utf8 environment (like LANG= mc). I also found out that bash-2.05a doesn't have this problem and the latest rawhide bash-2.05b-11 behaves somewhat differently (changing directories is a bit faster but 'LANG= mc' doesn't work anymore). btw, why is bash so slow when pasting big (half a page) portions of text? I think this has something to do with UTF.

Comment 4 Havoc Pennington 2003-02-03 23:08:14 UTC
I'm lost on whether/when/with-what-versions there is still a problem.

Is there a bug here in phoebe 2 or latest rawhide?


Comment 5 Leonard den Ottolander 2004-08-24 21:33:19 UTC
I don't think this problem exists any more. Never experienced it on
RHL 9 or FC 1. Closing.