Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79087

Summary: First Ctrl press gets lost with XDM xlogin widget
Product: [Retired] Red Hat Linux Reporter: Ton Kersten <ton.kersten>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED CURRENTRELEASE QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: low    
Version: 7.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-19 10:51:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Work around. Presses Ctrl key once. none

Description Ton Kersten 2002-12-05 14:52:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
We are using the XDM display manager and when the login screen appears we try to
switch to a virtual console (1-6) we almost always 'lose' the first time the
Control key is pressed. The second time always works. We see this behaviour when
logging in through X as well. We didn't try KDM and GDM, because we don't want
them on these systems.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Start a machine with a login screen from XDM's xlogin widget
2.When the login appears press Ctrl and (eg) F1. The system just beeps. Release
the keys
3.Press Ctrl and F1 again and it works
	

Actual Results:  Everythings works OK, but it is rather anoying because our
application relies on a lot of Ctrl key combo's

Expected Results:  The first Ctrl should be accepted

Additional info:

We created a work around, with a little C program that 'presses' the Ctrl button
every time xdm starts. It will be sent along as an attachment.

Comment 1 Ton Kersten 2002-12-05 14:54:33 UTC
Created attachment 87526 [details]
Work around. Presses Ctrl key once.

Comment 2 Mike A. Harris 2002-12-06 08:08:14 UTC
Are you using a KVM switch?

Comment 3 Ton Kersten 2002-12-06 08:18:11 UTC
No, I don't. I directly use the system keyboard, screen and mouse.

Comment 4 Mike A. Harris 2002-12-19 10:51:17 UTC
I'm unable to reproduce this in RHL 7.2, 7.3, 8.0, or rawhide XFree86.
Closing as CURRENTRELEASE, as it works for me, and it is quite a trivial
issue that if you were to provide a way to reproduce it reliably to me,
it would be very low priority, and only stand a chance of getting fixed
in rawhide due to that.