Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79062

Summary: [META-BUG] Severe keybord input corruption for many locales
Product: [Retired] Red Hat Linux Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: high    
Version: 8.0CC: bpinf, cefrodrigues, drdoom, gilles.chauvin, menthos, nacase, olivier.benghozi+redhatbugzilla, sblaisot, simon.matter, ttlquestor, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-26 21:28:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 71136, 79063, 79064, 79065, 79066    
Bug Blocks:    

Description Nicolas Mailhot 2002-12-05 09:30:22 UTC
The speakup patch included in recent Red Hat kernels messes up <ALT-GR> key
processing.

This is a major key on many european keybords. For example on a french keyboard
you need it to access <~>, <#>, <{>, <[>, <|>, <`>, <\>, <^>, <@>, <]>, <}>.

The bug occurs both on the console and in X. While not systematic (i.e not for
each key strike), it *will* occur during any meaningful user activity.

It was first reported in NULL, went into 8.0, and was propagated to Red Hat 7.0,
7.1, 7.2 and 7.3 via Red Hat errata.

There has been no public Red Hat activity on this bug since august 2002.

Comment 1 Nicolas Mailhot 2002-12-05 09:44:34 UTC
Well, I did the stupid thing and opened a specific bug for each affected Red Hat
version.

I kept the original bug report as the RH 8.0-specific entry.

Comment 2 Arjan van de Ven 2002-12-05 09:53:11 UTC
*** Bug 79066 has been marked as a duplicate of this bug. ***

Comment 3 Arjan van de Ven 2002-12-05 09:53:31 UTC
*** Bug 79065 has been marked as a duplicate of this bug. ***

Comment 4 Arjan van de Ven 2002-12-05 09:53:50 UTC
*** Bug 79064 has been marked as a duplicate of this bug. ***

Comment 5 Arjan van de Ven 2002-12-05 09:54:08 UTC
*** Bug 79063 has been marked as a duplicate of this bug. ***

Comment 6 Christian Rose 2002-12-14 20:07:23 UTC
A problem report was posted to the speakup mailing list. You can read the thread
at this address:
http://speech.braille.uwo.ca/pipermail/speakup/2002-December/018724.html

Comment 7 Sebastien BLAISOT 2003-01-06 08:14:41 UTC
seems to have been corrected in kernel-2.4.18-19.8.0 from updates. don't see the
problem with that kernel.

Comment 8 Christian Rose 2003-01-06 10:42:20 UTC
I can confirm that, haven't noticed the problem in the most recent errata kernel.

Comment 9 Nicolas Mailhot 2003-02-26 21:28:18 UTC
Seems this time its definitely fixed in erratas.

I'll close the bug now.