Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79059

Summary: pam_smbpass.so is no longer
Product: [Retired] Red Hat Linux Reporter: Michael Schwendt <bugs.michael>
Component: rhl-cgAssignee: Tammy Fox <tammy.c.fox>
Status: CLOSED ERRATA QA Contact: Tammy Fox <tammy.c.fox>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: chris.ricker, fenlason, mitr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-11 05:41:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Schwendt 2002-12-05 07:41:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

Description of problem:
The section on PAM module pam_smbpass.so at the bottom of "Configuring Samba" is
obsolete because Psyche does not ship with pam_smbpass.so.

http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual/custom-guide/s1-samba-configuring.html

Version-Release number of selected component (if applicable):
rhl-cg(EN)-8.0-HTML-RHI (2002-08-14T17:28-0400)

Additional information: bug #76745

Comment 1 Tammy Fox 2002-12-12 21:42:27 UTC
I am trying to find out if leaving this module out was a mistake or on
purpose.

Comment 2 Jack Tanner 2003-01-31 18:54:50 UTC
What is the status of this?

I got here because with that pam_smbpass.so entry in /etc/pam.d/system-auth, I'd
get something like this:

# passwd user
(user) Enter current password:
passwd: Module is unknown

It was a stroke of luck (a back-up /etc/pam.d/system-auth) that saved my butt.

Comment 3 Jay Fenlason 2003-02-10 22:58:24 UTC
Also see bug #78881.

Comment 4 Tammy Fox 2003-02-11 05:41:45 UTC
OK. So I will keep the section in future versions of the manual since it has
been added back to the package.

I'll also add a docs errata stating that the module was not included in RHL 8.0
but will be included in a future errata.