Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 79011

Summary: Errata qt-3.0.5-7.14 does not provide "libqt.so.3"
Product: [Retired] Red Hat Linux Reporter: Philip Rowlands <phr>
Component: qtAssignee: Ngo Than <than>
Status: CLOSED WONTFIX QA Contact: Ben Levenson <benl>
Severity: low Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-04 17:26:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Philip Rowlands 2002-12-04 15:55:34 UTC
The recently released errata package qt-3.0.5-7.14.i386.rpm does not declare the same "provide" resources as the previous version:

$ rpm -qp --provides qt-3.0.5-7.14.i386.rpm
libeditor.so.1
libqt-mt.so.3
libqui.so.1
qt = 1:3.0.5-7.14
$ rpm -qp --provides qt-3.0.3-11.i386.rpm
qt3
libqt.so.3
libeditor.so.1
libqt-mt.so.3
libqui.so.1
qt = 1:3.0.3-11

As a result, packages which depend upon libqt.so.3 prevent the errata upgrade, e.g. opera.

Comment 1 Ngo Than 2002-12-04 17:25:56 UTC
oh yes, i can confirm it. For workaround you should update it with --nodeps.


Comment 2 Ngo Than 2002-12-08 17:51:55 UTC
I want to close this bug as wontfix, because it's only effected by installing
"none-redhat" rpms.


Comment 3 Philip Rowlands 2002-12-09 00:07:14 UTC
I disagree with this resolution, but it's your OS. Could I suggest refining 
your QA procedure for errata packages to check that provides/requires do not 
change.