Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78984

Summary: pppd + laptop with only USB port + Nokia 6210 does not work
Product: [Retired] Red Hat Linux Reporter: MIchael Kolmodin <michael>
Component: pppAssignee: Thomas Woerner <twoerner>
Status: CLOSED NOTABUG QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
URL: n/a
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-08-16 16:14:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 70200, 78958, 78961, 78962, 79070    
Bug Blocks:    

Description MIchael Kolmodin 2002-12-04 11:16:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
This is a meta bug covering the difficulties to connect a laptop with a
USB-connected serial port through a Nokia phone to an ISP

Current work-around is a kermit script which connects and then enters 
transparent mode. This script is fed as pty argument to pppd. Far from
elegant, but I havn't found any other solution so far. There are numerous
ppp-up. ppp-down, and /sbin/ifup-pre-local scripts involved to get it running.

Version-Release number of selected component (if applicable):
RH 7.2, kernel update 2.4.18-17.8.7x

Dependencies:
bug 70200:  ifdown-post removes ppp peers' config
bug 78958:  lcp-echo* options blocks pppd from connecting
bug 78961:  Wvdial does not handle baud rate recognition?
bug 78962:  USB serial driver doesn't support DCD/DSR/DTS

In short: 78962 is the very root. If the driver supported hardware signals, a
normal chat script could be used, no lcp-echo* would be required and no peer
configuration would be needed.

Even if 78962 is not solved, solving 78961 would make the use of peer
configurations obsolete. In this scenario, I can live with 78962 for a while.

Comment 1 MIchael Kolmodin 2002-12-04 11:19:30 UTC
Adding formal dependencies

Comment 2 MIchael Kolmodin 2002-12-05 11:33:28 UTC
Adding 79070 dependency after splitting 79062 into two bugs; this is the new one.

Comment 3 Thomas Woerner 2004-08-16 16:14:21 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.