Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78980

Summary: Non-root LVM partitions fail when added to fstab
Product: [Retired] Red Hat Linux Reporter: lee.essen
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-04 10:06:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description lee.essen 2002-12-04 10:06:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

Description of problem:
See bug 77539 - which is closed as "notabug" which I believe is wrong.

When you take a system with no LVM partitions and add one (say /fred) and add
that to the fstab, when you reboot the system the fsck on the filesystem with
fail because the LVM initialisation didn't happen because the LVM module is not
loaded.

Previous reports of this bug have been closed because "you need to include the
LVM in the initrd" ... which is fine, but it isn't intuitive and mkinitrd won't
include the module by default unless the root filesystem is on a LV (which means
each time I upgrade my kernel I will break my machine again!)

There are several other modprobes in rc.sysinit, and additional LVM one wouldn't
hurt (if /etc/lvmtab exists etc).

Or, if this really can't be done, then this problem (and workaround) should be
clearly documented where people are going to find it when they start playing
with LVM.

It's small useability inconsistancies like this that scare people away from Linux.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build a non-LVM system
2. Create a LV based filesystem and add it to fstab
3. Reboot
	

Actual Results:  fsck fails because LVM initialisation is not done.

Expected Results:  No fsck problems (and correct LVM initialisation)

Additional info:

Comment 1 Bill Nottingham 2002-12-04 17:30:55 UTC
This is tweaked in the current initscripts in rawhide; as long as an lvmtab
exists, the module will be loaded.