Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78905

Summary: ncftpget displays progress bar when not on tty
Product: [Retired] Red Hat Raw Hide Reporter: Jonathan Kamens <jik>
Component: ncftpAssignee: Karsten Hopp <karsten>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: michael
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-04 17:46:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jonathan Kamens 2002-12-03 11:09:36 UTC
I have a script which does an ncftpget in a cron job.  It just started blatting
progress bar crap into the output of the cron job.  It didn't used to do this --
presumably, ncftpget previously was smart enough to notice when it wasn't
running on a tty and suppress the progress bar, but this has been broken.  I'm
running ncftp-3.1.5-1.

Comment 1 Michael Lee Yohe 2002-12-04 17:46:29 UTC
I don't think this is a bug since there is an option to disable the progress bar
for ncftpget.  

$ ncftpget --help
NcFTPGet 3.1.3

<snip>
  -v/-V  Do (do not) use progress meters.

So, if you add the "-V" option to your cron job, you should not see the progress
meter stuff in your output.


Comment 2 Karsten Hopp 2002-12-04 20:02:56 UTC
A simple update of a package shouldn't break scripts if possible. 
The check for tty was disabled in 3.1.5-1. I've re-enabled it in  
3.1.5-2